Bug 1279948 - Missing dependencies
Missing dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tesseract (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karol Trzcionka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 09:53 EST by kluksa
Modified: 2015-11-11 03:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 03:00:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kluksa 2015-11-10 09:53:44 EST
Description of problem:
tesseract requires liblept.so.3 which is not packaged in Fedora 23. Binary is linked with both liblept.so.3.

Quick and dirty fix:
simlinking /lib64/liblept.so.3 to  /lib64/liblept.so.4

Version-Release number of selected component (if applicable):
tesseract-3.04.00-1.fc23.x86_64

Steps to Reproduce:
1. tesseract image_file.png

Actual results:
tesseract: error while loading shared libraries: liblept.so.3: cannot open shared object file: No such file or directory

Additional info:
ldd /usr/bin/tesseract

	linux-vdso.so.1 (0x00007ffdab3c7000)
	libtesseract.so.3 => /home/kraljevic/local/lib/libtesseract.so.3 (0x00007faa86d7e000)
	librt.so.1 => /lib64/librt.so.1 (0x00007faa86b4a000)
	liblept.so.4 => /lib64/liblept.so.4 (0x00007faa8670a000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007faa864ed000)
	libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007faa8616a000)
	libm.so.6 => /lib64/libm.so.6 (0x00007faa85e68000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007faa85c51000)
	libc.so.6 => /lib64/libc.so.6 (0x00007faa8588f000)
	liblept.so.3 => not found
	libz.so.1 => /lib64/libz.so.1 (0x00007faa85679000)
	libpng16.so.16 => /lib64/libpng16.so.16 (0x00007faa85445000)
	libjpeg.so.62 => /lib64/libjpeg.so.62 (0x00007faa851ec000)
	libgif.so.4 => /lib64/libgif.so.4 (0x00007faa84fe2000)
	libtiff.so.5 => /lib64/libtiff.so.5 (0x00007faa84d6e000)
	libwebp.so.5 => /lib64/libwebp.so.5 (0x00007faa84b0f000)
	/lib64/ld-linux-x86-64.so.2 (0x000055f6174db000)
	libSM.so.6 => /lib64/libSM.so.6 (0x00007faa84905000)
	libICE.so.6 => /lib64/libICE.so.6 (0x00007faa846e9000)
	libX11.so.6 => /lib64/libX11.so.6 (0x00007faa843a9000)
	libjbig.so.2.1 => /lib64/libjbig.so.2.1 (0x00007faa8419c000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007faa83f97000)
	libxcb.so.1 => /lib64/libxcb.so.1 (0x00007faa83d75000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007faa83b70000)
	libXau.so.6 => /lib64/libXau.so.6 (0x00007faa8396c000)


dnf provides */liblept.so.3
Error: No Matches found


rpm -qR tesseract-3.04.00-1.fc23.x86_64
/sbin/ldconfig
/sbin/ldconfig
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.15)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libcairo.so.2()(64bit)
libfontconfig.so.1()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libicui18n.so.54()(64bit)
libicuuc.so.54()(64bit)
liblept.so.4()(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libpango-1.0.so.0()(64bit)
libpangocairo-1.0.so.0()(64bit)
libpangoft2-1.0.so.0()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
librt.so.1()(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(CXXABI_1.3.8)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libstdc++.so.6(GLIBCXX_3.4.18)(64bit)
libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libtesseract.so.3()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Comment 1 Sandro Mani 2015-11-10 09:58:40 EST
This looks like a conflict with a binary which was installed from another repo, at least tesseract is linked only against liblept.so.4. 

Please look with lddtree from pax-utils where the liblept.so.3 dependency is actually coming from.
Comment 2 kluksa 2015-11-11 03:00:14 EST
(In reply to Sandro Mani from comment #1)
> This looks like a conflict with a binary which was installed from another
> repo, at least tesseract is linked only against liblept.so.4. 
> 

Yes it was. Sorry to bother.

Note You need to log in before you can comment on or make changes to this bug.