Bug 127996 - can't activate the IM on kate and konsole
can't activate the IM on kate and konsole
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 03:26 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 06:07:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-07-16 03:26:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
since the immodules for Qt patch has been applied, kate and konsole
doesn't work to input the native languages so that kdelibs is missing
to call setInputMethodEnabled(true).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run KDE with CJK locales on the machine IIIMF installed.
2.run konsole or kate
3.press ctrl+space
    

Actual Results:  nothing happens

Expected Results:  the status window is shown. and start to input the
native language.

Additional info:

the patches are available:
http://www.kde.gr.jp/~daisuke/immodule_for_qt/patch/unstable/kdebase-3.2.2-konsole-setInputMethodEnabled-20040525.diff
http://www.kde.gr.jp/~daisuke/immodule_for_qt/patch/unstable/kdelibs-3.2.2-kate-setInputMethodEnabled-20040525.diff
Comment 1 Leon Ho 2004-07-18 20:21:54 EDT
It would be great if you can apply those patches. They are in kde cvs
trunk so they will be in the next release of kde. However 3.2.2's kate
and konsole won't work for input method if those are not applied. Thanks
Comment 2 Ngo Than 2004-07-19 06:07:20 EDT
sure, it will be in next rebuild. Thanks

Note You need to log in before you can comment on or make changes to this bug.