Bug 1280004 - Balloon device should be enabled by default for new VMs
Balloon device should be enabled by default for new VMs
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Tomas Jelinek
sefi litmanovich
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 12:11 EST by Martin Sivák
Modified: 2016-02-18 06:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:10:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48723 master MERGED core: add memballoon by default to blank template Never
oVirt gerrit 49629 ovirt-engine-3.6 MERGED core: add memballoon by default to blank template Never

  None (edit)
Description Martin Sivák 2015-11-10 12:11:00 EST
Description of problem:

The balloon device is disabled in the Blank template. This causes all VM created from that template to miss a device that we need for any memory related QoS (ballooning, KSM).

It is not possible to hot-plug the ballooning device during VM runtime so all VM started without it have to be restarted to get it.

Average users are not usually checking the Resource allocation subtab when creating new VM and might be surprised by the fact that ballooning does not work for new VMs.

Version-Release number of selected component (if applicable):

ovirt-engine 3.6.0

How reproducible:

Just go to the Blank template and open the Resource allocation subtab.


Expected results:

Ballooning device is enabled by default.
Comment 1 Michal Skrivanek 2015-11-13 11:07:28 EST
adding it to Blank should solve this
Regression from 3.5
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-13 11:17:36 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Sandro Bonazzola 2015-12-23 08:44:06 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 4 sefi litmanovich 2016-01-07 04:16:10 EST
Verified with rhevm-3.6.2-0.1.el6.noarch.

1. Blank template -> Resource allocation tab -> Memory Balloon Device Enabled is checked.
2. Create new vm (Based on Blank template) -> Resource allocation tab -> Memory Balloon Device Enabled is checked.

Note You need to log in before you can comment on or make changes to this bug.