Bug 1280008 - PyQt visual oddities during edits of text fields
PyQt visual oddities during edits of text fields
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qt (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks: 1297830
  Show dependency treegraph
 
Reported: 2015-11-10 12:24 EST by Jacob Hunt
Modified: 2016-02-24 04:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 04:39:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer script (898 bytes, text/x-python)
2015-11-10 12:24 EST, Jacob Hunt
no flags Details
Video of reproducer (61.38 KB, application/octet-stream)
2015-11-19 10:21 EST, Jacob Hunt
no flags Details

  None (edit)
Description Jacob Hunt 2015-11-10 12:24:49 EST
Created attachment 1092372 [details]
reproducer script

Description of problem:

In a simple PyQt QTableWidget if you edit a text field that has data already, your edits are shown superimposed over the existing data. In addition, if the data is highlighted and then 'deleted', it is still displayed as if it were there.

I would expect data to disappear when being edited (whole or partially)

Version-Release number of selected component (if applicable):

PyQt4-4.10.1-13.el7.x86_64

How reproducible:

always
Comment 4 Jacob Hunt 2015-11-19 10:21 EST
Created attachment 1096720 [details]
Video of reproducer
Comment 9 Ngo Than 2015-11-23 13:08:57 EST
it's affected in qt (the qt demo) too, reassign to correct component qt
Comment 11 Jan Grulich 2016-01-19 05:09:32 EST
After some investigation it looks that the problem is in GTK+ style used when running Qt app on Gnome, using qtconfig-qt4 to force to use Oxygen makes this work under Gnome too. I'll try to investigate this further.
Comment 16 Jan Grulich 2016-02-24 04:39:13 EST
Closing this bug, we are not going to support gtk+ style. There is a new theme we want to support and which customers should use. The new theme should be available in RHEL 7.3.

Note You need to log in before you can comment on or make changes to this bug.