Bug 1280121 - Advanced install method should instruct to git checkout a tag
Advanced install method should instruct to git checkout a tag
Status: CLOSED DUPLICATE of bug 1288142
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ashley Hardin
Ma xiaoqiang
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 19:19 EST by Jason Callaway
Modified: 2016-07-03 20:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 11:58:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Callaway 2015-11-10 19:19:07 EST
Document URL: 
https://docs.openshift.com/enterprise/3.0/install_config/install/advanced_install.html

Section Number and Name: 
Cloning the Ansible repository

Describe the issue: 
As the documentation is now, the user is instructed to use the "nightly" openshift-ansible repo, or whatever is at HEAD of master.

Suggestions for improvement: 
The user should be instructed to check out the tag that maps to the version of OSE that they're using. For example, if the user is using OSE 3.0.2.0, the last command in the code block should be:
# git checkout tags/v3.0.2-2

Additional information: 
The user should be instructed to check GitHub for the latest release of the tag, i.e., -2 in the above example instead of -1. This could be done either by using the GitHub webconsole Branch/Tag dropdown, or something like the following from the openshift-ansible directory:
# git tag | grep v3.0.2 | sort | tail -1
v3.0.2-2
Comment 2 Ashley Hardin 2016-02-24 11:58:43 EST
For 3.0 we need to update the repo cloning content to use a-o-installer anyway.

*** This bug has been marked as a duplicate of bug 1288142 ***

Note You need to log in before you can comment on or make changes to this bug.