Bug 1280184 - Result of subscription-manager shows registered but not subscribed [NEEDINFO]
Result of subscription-manager shows registered but not subscribed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 01:25 EST by yangbo.jiang
Modified: 2016-02-01 15:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 15:34:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jsefler: needinfo? (yangbo.jiang)


Attachments (Terms of Use)

  None (edit)
Description yangbo.jiang 2015-11-11 01:25:04 EST
Description of problem:
After subscribe successfully, it still display "not subscribed"

[root@nchyp194107 ~]# subscription-manager subscribe --pool=8a85f9814a192108014a1c40a0b02bb0
Successfully attached a subscription for: Red Hat Enterprise Virtualization Business Partner Supported NFR (10 sockets/25 desktops)
[root@nchyp194107 ~]# subscription-manager list

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        7.1
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not supported by a valid subscription.
Starts:
Ends:

I tried auto-attach, always doesn't work. 
[root@nchyp194107 ~]# subscription-manager register --username username --password password --auto-attach --force
The system with UUID ffc8dc11-82e1-4456-946a-a9e1c26c22a5 has been unregistered
The system has been registered with ID: 9769d2d3-14a1-4d2d-9b87-18a78f9250c9

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
"Not Subscribed"

Expected results:
"Subscribed"

Additional info:
Comment 2 John Sefler 2015-11-11 08:51:59 EST
It sounds like you have manually attached a subscription SKU for "Red Hat Enterprise Virtualization Business Partner Supported NFR (10 sockets/25 desktops)", but it it does not provide for the engineering product "Red Hat Enterprise Linux Server" which is clearly installed on your system.  Run 'subscription-manager list --consumed' to see what subscriptions you have attached to your system and the "Provides:" field will show what engineering products the SKU supports.  You'll need to attach a pool that actually provides "Red Hat Enterprise Linux Server" in order to become green.

Because you attempted to register with --auto-attach and you did not get a subscription for your installed product, it sounds like your account does not have an available subscription that provides "Red Hat Enterprise Linux Server".  That could be a problem with your account.  Another possibility is that the pool in your account has been depleted by other consumers in your organization and there ar no more entitlements left for you.


Run "rhsm-debug system" and attach the zip file that is created to this bugzilla to provide more information for troubleshooting your issue.
Comment 3 Barnaby Court 2016-02-01 15:34:42 EST
Closing due to lack of response to the request for more information in Comment 2. Please re-open with information requested in Comment 2 if you are still encountering this issue.

Note You need to log in before you can comment on or make changes to this bug.