Bug 128022 - lilo fails silently on error after kernel upgrade
lilo fails silently on error after kernel upgrade
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lilo (Show other bugs)
3.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 10:04 EDT by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:22:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2004-07-16 10:04:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040623

Description of problem:
After applying the kernel v2.4.21-15.0.3.E update made available via
up2date, lilo fails to install this new kernel.

Attempts to install the kernel cause lilo to exit immediately having
done nothing. No error message is logged. Running lilo through strace
gives the following:

[snip]
open("/etc/lilo.conf", O_RDONLY)        = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=421, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xb75e9000
read(3, "prompt\ntimeout=10\ndefault=2.4.21"..., 4096) = 421
fstat64(3, {st_mode=S_IFREG|0644, st_size=421, ...}) = 0
open("/dev/md1", 0x4)                   = 4
fstat64(4, {st_mode=S_IFBLK|0660, st_rdev=makedev(9, 1), ...}) = 0
ioctl(4, 0x80480911, 0xbfffd1b0)        = 0
ioctl(4, 0x80140912, 0xbfffd190)        = 0
exit_group(0)                           = ?

/dev/md1 exists and is mounted correctly:

[root@chandler redhat]# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md3               2015952   1644596    268948  86% /
/dev/md1                 23302     14711      7388  67% /boot
/dev/md5               2048060   1933916    114144  95% /var
/dev/md6               2048060   1528612    519448  75% /var/www
/dev/md8               8191616   7266548    925068  89% /home
none                    256784         0    256784   0% /dev/shm

lilo.conf looks like this:

prompt
timeout=10
default=2.4.21-15.0.3.E
#default=linux.bak
boot=/dev/md1
map=/boot/map
install=/boot/boot.b
linear
append="console=ttyS0,9600,8,N,1 console=tty0"
 
image=/boot/vmlinuz-2.4.21-15.0.3.EL
        label=2.4.21-15.0.3.E
        initrd=/boot/initrd-2.4.21-15.0.3.EL.img
        read-only
        root=/dev/md3
 
image=/boot/vmlinuz-2.4.21-15.0.2.EL
        label=2.4.21-15.0.2
        initrd=/boot/initrd-2.4.21-15.0.2.EL.img
        read-only
        root=/dev/md3

If an error is present, lilo should fail with an error, and not exit
silently having done nothing, as it does now. This leaves the admin
having to stab around in the dark looking for the problem, which will
only be found by accident.


Version-Release number of selected component (if applicable):
lilo-21.4.4-23.1

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Scott Taylor 2005-02-02 10:35:07 EST
"lilo -t" (test) returns a string to STDERR with error level of 0, so
maybe it looks like an error to your up2date program, but it is not.
 
Comment 2 Peter Jones 2005-03-30 16:20:56 EST
Are any of the drives in a failed/depricated state?
Comment 3 RHEL Product and Program Management 2007-10-19 15:22:37 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.