Bug 1280233 - Openstack Instance SmartState Analysis fails when the instance is booted from volume snapshot
Openstack Instance SmartState Analysis fails when the instance is booted from...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:00 EST by Marius Cornea
Modified: 2015-11-11 15:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 07:07:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evm log (8.58 KB, text/plain)
2015-11-11 05:00 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-11-11 05:00:44 EST
Created attachment 1092623 [details]
evm log

Description of problem:
SmartState Analysis fails for an Openstack instance which is booted from a volume snapshot. 

Version-Release number of selected component (if applicable):
5.5.0.10-beta2.1.20151110134042_d6f5459

How reproducible:
100%

Steps to Reproduce:
1. Add Openstack Cloud provider
2. Boot up instance from volume snapshot
3. Run SmartState Analysis on the instance

Actual results:
Nothing shows up in the UI. Error message shows up in the evm.log

Expected results:
Display the result on the UI.

Additional info:
Attaching the evm.log.

ERROR -- : Unable to mount filesystem.  Reason:[Image: EvmSnapshot (a9ed8f44-d9f1-4ff7-90ea-2652e95b77df) is empty] for VM [fb2e2f88-b123-4273-bd4b-724fe2005697]

The glance image that's been used for boot has 0 size:
| 2b88e1c2-8c38-48ca-bfbb-1effe4105707 | EmsRefreshSpec-PoweredOn-SnapShot | ami         | ami              |          | active |
Comment 2 Marius Cornea 2015-11-11 07:07:39 EST
I'm going to close this as not a bug. The error message is displayed in the Analysis History:

Message Unable to mount filesystem. Reason:[Image: EvmSnapshot (36f75f57-c872-452c-b70d-497ab7fefaf9) is empty]

Note You need to log in before you can comment on or make changes to this bug.