Bug 1280251 - Can't update template display disconnect action
Can't update template display disconnect action
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Database.Core (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:38 EST by Juan Hernández
Modified: 2016-02-18 06:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:19:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
rule-engine: planning_ack?
michal.skrivanek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48739 master MERGED db: Add console_disconnect_action on VM Templates Never
oVirt gerrit 49084 ovirt-engine-3.6 MERGED db: Add console_disconnect_action on VM Templates Never

  None (edit)
Description Juan Hernández 2015-11-11 05:38:54 EST
This issue was reported by Cristian Mammoli in the oVirt users list:

  http://lists.ovirt.org/pipermail/users/2015-November/035827.html

In 3.6 it is not possible to change display disconnect policy in templates. Well, you can change it and save but when you go back to the config it goes back to lock_screen.

It does not work even with shell:

[oVirt shell (connected)]# update template vdiMaster 
--display-disconnect_action NONE | grep display-disconnect_action
display-disconnect_action    : LOCK_SCREEN

It works fine in VMS though.
Comment 1 Juan Hernández 2015-11-11 05:40:55 EST
The reason for this is that the "v_console_disconnect_action" that was added to the "UpdateVmStatic" procedure wasn't added to the "UpdateVmTemplate" procedure, thus it is simply ignored.
Comment 2 Sandro Bonazzola 2015-12-23 08:43:20 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 3 Jiri Belka 2016-01-05 11:44:35 EST
ok, rhevm-backend-3.6.2-0.1.el6.noarch

[RHEVM shell (connected)]# show template vdcadmin | grep disconnect_action
display-disconnect_action    : LOCK_SCREEN
[RHEVM shell (connected)]# update template vdcadmin --display-disconnect_action NONE    
...
[RHEVM shell (connected)]# show template vdcadmin | grep disconnect_action
display-disconnect_action    : NONE

work both via shell and web UI.

Note You need to log in before you can comment on or make changes to this bug.