Bug 1280256 - maven-assembly-plugin uses incompatible api
maven-assembly-plugin uses incompatible api
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-assembly-plugin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:49 EST by Severin Gehwolf
Modified: 2015-11-12 08:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 08:12:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2015-11-11 05:49:56 EST
Description of problem:
A recent thermostat rawhide build fails due to maven-assembly-plugin failing with this:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.6:single (assemble-plugin) on project thermostat-host-cpu-distribution: Execution assemble-plugin of goal org.apache.maven.plugins:maven-assembly-plugin:2.6:single failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-assembly-plugin:2.6:single: java.lang.NoSuchMethodError: org.apache.maven.shared.filtering.MavenReaderFilterRequest.<init>(Ljava/io/Reader;ZLorg/apache/maven/project/MavenProject;Ljava/util/List;ZLjava/lang/String;Lorg/apache/maven/execution/MavenSession;Ljava/util/Properties;)V
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>org.apache.maven.plugins:maven-assembly-plugin:2.3
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/usr/share/java/maven-assembly-plugin/maven-assembly-plugin.jar
[ERROR] urls[1] = file:/builddir/build/BUILD/thermostat-1.4.0/assembly/target/thermostat-assembly-1.4.0.jar
[ERROR] urls[2] = file:/usr/share/java/org.eclipse.sisu.inject.jar
[ERROR] urls[3] = file:/usr/share/java/maven/maven-builder-support.jar
[ERROR] urls[4] = file:/usr/share/java/guava.jar
[ERROR] urls[5] = file:/usr/share/java/aether/aether-util.jar
[ERROR] urls[6] = file:/usr/share/java/guice/google-guice-no_aop.jar
[ERROR] urls[7] = file:/usr/share/java/aopalliance.jar
[ERROR] urls[8] = file:/usr/share/java/plexus-containers/plexus-component-annotations.jar
[ERROR] urls[9] = file:/usr/share/java/plexus/plexus-sec-dispatcher.jar
[ERROR] urls[10] = file:/usr/share/java/plexus/plexus-cipher.jar
[ERROR] urls[11] = file:/usr/share/java/objectweb-asm/asm-commons.jar
[ERROR] urls[12] = file:/usr/share/java/objectweb-asm/asm-tree.jar
[ERROR] urls[13] = file:/usr/share/java/objectweb-asm/asm.jar
[ERROR] urls[14] = file:/usr/share/java/xbean/xbean-reflect.jar
[ERROR] urls[15] = file:/usr/share/java/maven-common-artifact-filters/maven-common-artifact-filters.jar
[ERROR] urls[16] = file:/usr/share/java/maven-shared-utils/maven-shared-utils.jar
[ERROR] urls[17] = file:/usr/share/java/jsr-305.jar
[ERROR] urls[18] = file:/usr/share/java/plexus/interpolation.jar
[ERROR] urls[19] = file:/usr/share/java/plexus/archiver.jar
[ERROR] urls[20] = file:/usr/share/java/commons-compress.jar
[ERROR] urls[21] = file:/usr/lib/java/snappy-java/snappy-java.jar
[ERROR] urls[22] = file:/usr/share/java/maven-file-management/file-management.jar
[ERROR] urls[23] = file:/usr/share/java/maven-shared-io/maven-shared-io.jar
[ERROR] urls[24] = file:/usr/share/java/commons-io.jar
[ERROR] urls[25] = file:/usr/share/java/maven-filtering/maven-filtering.jar
[ERROR] urls[26] = file:/usr/share/java/plexus/plexus-build-api.jar
[ERROR] urls[27] = file:/usr/share/java/plexus/io.jar
[ERROR] urls[28] = file:/usr/share/java/maven-archiver/maven-archiver.jar
[ERROR] urls[29] = file:/usr/share/java/plexus/utils.jar
[ERROR] urls[30] = file:/usr/share/java/maven-repository-builder/maven-repository-builder.jar
[ERROR] urls[31] = file:/usr/share/java/commons-codec.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent: null]]

Version-Release number of selected component (if applicable):
maven-assembly-plugin-2.6-2.fc24.noarch

How reproducible:
100%

Steps to Reproduce:
1. fedpkg clone -a thermostat
2. cd thermostat && fedpkg mockbuild

Actual results:
Failed build.

Expected results:
Build passes.

Additional info:
It did build successfully yesterday[1].

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=697729
Comment 1 Mikolaj Izdebski 2015-11-12 08:12:00 EST
This has already been fixed on Tuesday.
Comment 2 Mikolaj Izdebski 2015-11-12 08:12:09 EST
I believe that this bug is fixed in maven-assembly-plugin-2.6-3,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=697289

Note You need to log in before you can comment on or make changes to this bug.