This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1280295 - [abrt] docker-compose: service.py:12:<module>:ImportError: cannot import name create_host_config
[abrt] docker-compose: service.py:12:<module>:ImportError: cannot import name...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8a36fe0309225f83425d6dd17d5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 07:24 EST by Yajo
Modified: 2015-11-12 06:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 06:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.53 KB, text/plain)
2015-11-11 07:24 EST, Yajo
no flags Details
File: environ (1.01 KB, text/plain)
2015-11-11 07:24 EST, Yajo
no flags Details

  None (edit)
Description Yajo 2015-11-11 07:24:11 EST
Description of problem:
docker-compose restart app

Version-Release number of selected component:
docker-compose-1.4.2-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python2 /usr/bin/docker-compose restart app
dso_list:       python-setuptools-18.0.1-2.fc23.noarch
executable:     /usr/bin/docker-compose
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/compose/service.py:12
#2 <module> in /usr/lib/python2.7/site-packages/compose/project.py:12
#3 <module> in /usr/lib/python2.7/site-packages/compose/cli/main.py:16
#4 resolve in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2361
#5 load in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2355
#6 load_entry_point in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:2682
#7 load_entry_point in /usr/lib/python2.7/site-packages/pkg_resources/__init__.py:558
#8 <module> in /usr/bin/docker-compose:9
Comment 1 Yajo 2015-11-11 07:24:15 EST
Created attachment 1092680 [details]
File: backtrace
Comment 2 Yajo 2015-11-11 07:24:16 EST
Created attachment 1092681 [details]
File: environ
Comment 3 Michael Hampton 2015-11-11 07:56:05 EST
I suspect that you were running a pre-release version of F23. Please update python-docker-py to release version (1.3.1-1) and try again.
Comment 4 Yajo 2015-11-12 04:27:39 EST
That's the version I have installed.
Comment 5 Michael Hampton 2015-11-12 05:44:14 EST
I can't reproduce this on a freshly installed F23. docker-compose restart <name> is simply restarting the container as expected.

There are some things you can try:

* Ensure that you're up to date, with: dnf distro-sync
* Verify the integrity of installed RPMs, with: rpm -Va
  (And dnf reinstall any RPMs which have corrupt or missing files)

In particular, I suspect your python-docker-py package is not installed correctly, has corrupt or missing files, or is unreadable for some reason. You may try reinstalling this package.
Comment 6 Yajo 2015-11-12 06:44:06 EST
None of those worked.

However, I investigated more through a python shell and discovered that I had some packages left in my user's pip path.

This fixed it: rm -Rf ~/.local/lib/

Thanks!

Note You need to log in before you can comment on or make changes to this bug.