Bug 128030 - python help command can't find the python documentation
Summary: python help command can't find the python documentation
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 136091 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-16 15:11 UTC by Robin Green
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.3.4-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 12:27:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robin Green 2004-07-16 15:11:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040622

Description of problem:
I tried to look up the documentation for "print" with the
help("print") command, but I got an error about documentation not
being found, despite the fact that I'd install the python-docs RPM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start python
2. Type help("print")
    

Actual Results:  Sorry, topic and keyword documentation is not
available because the Python
HTML documentation files could not be found.  If you have installed them,
please set the environment variable PYTHONDOCS to indicate their location.


Expected Results:  Should have displayed docs

Additional info:

Obviously I can set PYTHONDOCS - but I think that either the python
RPM should be compiled such that it knows the correct place to find
the docs on a fedora system, OR the python-docs package should set the
PYTHONDOCS environment variable in /etc/profile.d. I favour the former
solution.

Comment 1 Mihai Ibanescu 2004-07-16 15:13:22 UTC
Agreed on the former, I'll see what I can do.

Comment 2 Mihai Ibanescu 2004-10-17 20:16:02 UTC
*** Bug 136091 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.