Bug 1280307 - [RFE] consider working with reboot option of fence-agents
[RFE] consider working with reboot option of fence-agents
Status: CLOSED DEFERRED
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
: FutureFeature
: 1280308 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 07:52 EST by Oved Ourfali
Modified: 2017-06-07 14:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 14:39:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Oved Ourfali 2015-11-11 07:52:11 EST
Description of problem:
Fence agent scripts check whether the host went down when doing reboot, so we can remove the logic we do in the engine, and replace it with calling the reboot option of the fence agents.

More details in
https://github.com/ClusterLabs/fence-agents/blob/master/fence/agents/lib/fencing.py.py

important lines starts at 820 where code switch for cycle / non-cycle. Non-cycle is what interested you, this code is covered at 832-851.
Comment 1 Oved Ourfali 2015-11-17 04:34:53 EST
When planning the additional refactoring points on fencing, we should consider this as well.
Comment 2 Oved Ourfali 2016-01-27 01:36:37 EST
Martin - I don't see us doing that anytime soon.
Putting ovirt-future.
If it turns out to be something simple or with high benefit then we'll re-target it accordingly.
Comment 3 Martin Perina 2016-03-21 06:54:13 EDT
*** Bug 1280308 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.