Bug 1280308 - consider working with reboot option of fence-agents
consider working with reboot option of fence-agents
Status: CLOSED DUPLICATE of bug 1280307
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 07:52 EST by Oved Ourfali
Modified: 2016-03-21 06:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 06:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.0.0?
oourfali: planning_ack?
oourfali: devel_ack?
oourfali: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Oved Ourfali 2015-11-11 07:52:34 EST
Description of problem:
Fence agent scripts check whether the host went down when doing reboot, so we can remove the logic we do in the engine, and replace it with calling the reboot option of the fence agents.

More details in
https://github.com/ClusterLabs/fence-agents/blob/master/fence/agents/lib/fencing.py.py

important lines starts at 820 where code switch for cycle / non-cycle. Non-cycle is what interested you, this code is covered at 832-851.
Comment 1 Martin Perina 2016-03-21 06:54:13 EDT

*** This bug has been marked as a duplicate of bug 1280307 ***

Note You need to log in before you can comment on or make changes to this bug.