Bug 1280368 - package iptables-services.x86_64 0:1.4.21-13.el7 has broken deps
package iptables-services.x86_64 0:1.4.21-13.el7 has broken deps
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:06 EST by Jaroslav Henner
Modified: 2017-01-12 10:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 10:18:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log (6.40 KB, text/plain)
2015-11-12 06:44 EST, Jaroslav Henner
no flags Details

  None (edit)
Description Jaroslav Henner 2015-11-11 10:06:05 EST
Description of problem:
trying to install it on rhel-guest-image 7.2 and/or 7.1 leads to pulling i686 packages


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. subscription-manager repos --disable="*"
   subscription-manager repos \
     --enable="rhel-7-server-rpms" \
     --enable="rhel-7-server-extras-rpms" \
     --enable="rhel-7-server-ose-3.0-rpms"

2. openstack server create \
	--image rhel-atomic-cloud-7.2-10 \
	--flavor m1.small \
	--key-name jhenner \
	--nic net-id=a91e3802-783e-40a8-aa3d-6332c1b4f836 \
	--user-data /tmp/atomic_cloud_data \
	atomic-experiment-3

3. openstack server create --image rhel-guest-image-7.2-20151102.0 --flavor m1.small --key-name jhenner $name --nic net-id=a91e3802-783e-40a8-aa3d-6332c1b4f836 --user-data /tmp/cloud_data;

Actual results:
yum fails on dep resolving

Expected results:
installed

Additional info:
Comment 2 Jan Stodola 2015-11-12 03:56:21 EST
Jaroslav,
could you please attach yum log?
Comment 3 Jaroslav Henner 2015-11-12 06:44 EST
Created attachment 1093186 [details]
yum log

Sorry, I failed to attach before. Here it is. Lucky I have huge scrollback buffer in my terminal.
Comment 4 Lubos Kocman 2017-01-12 08:36:15 EST
So the actual issue is that glibc-common is not multilib.

Also it's not really a depenedency issue of iptables-services.x86_64 0:1.4.21-13.el7 but rather of iptables-services.i686 0:1.4.21-13.el7 (multilib)

I'll check whether there is a reason not to have glibc-common as multilib and if there is then I'm going to close this as CAN'T FIX and recommend you to uninstall 32bit version of iptables.


Lubos
Comment 5 Lubos Kocman 2017-01-12 10:18:00 EST
So let me explain how do we add glibc-common into RHEL.

glibc is part of comps group I believe @base and glibc-common is being pulled in as dependency of glibc.x86_64. So inclusion of glibc-common is dependency driven

As far as multilib goes we do add glibc.i686 due several software requirements (again also multilibs)

-bash-4.1$ identify-rhel7-rpm glibc | grep "Added glibc.i686" | sort | uniq
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for alsa-lib.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for compat-libstdc++-33.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for fontconfig.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for freetype.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for glib2.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for java-1.7.1-ibm.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for krb5-libs.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for libcom_err.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for libselinux.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for libX11.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for nss-softokn-freebl.i686
Pungi:INFO: Added glibc.i686 (repo: lookaside-repo-0) for python-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for avahi-glib.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for cairo-gobject.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for compat-gcc-32.src
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for compat-libf2c-34.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for compat-libstdc++-33.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for compat-openldap.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for corosynclib.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for dbus-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for ElectricFence.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for elfutils-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for firefox.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for GConf2.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for glib2.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for glibc-devel.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for hesiod.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for ImageMagick.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for java-1.8.0-openjdk-headless-debug.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for java-1.8.0-openjdk-headless.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for js-devel.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for kdelibs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for krb5-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libasan.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libfabric.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libffi.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libgomp.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libgudev1.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libquadmath.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for librdmacm.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libref_array.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libselinux.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libstdc++.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libtdb.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libxml2.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for libxslt.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for lua.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for motif-devel.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for mozjs17.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for mpich-3.0.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for ncurses-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for nspr.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for nss-softokn-freebl.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for nss-softokn.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for openjpeg-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for openldap.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for openssl-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for pam.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for pcre.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for plymouth-core-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for polkit.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for pulseaudio-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for python-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for qt5-qtbase.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for qt.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for redhat-lsb-core.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for ruby-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for samba-client-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for systemd-libs.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for valgrind.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for vm-dump-metrics.i686
Pungi:INFO: Added glibc.i686 (repo: pungi-repo) for xz-libs.i686
-bash-4.1$ 

# Current depsolving for iptables looks fine also

Searching in /mnt/redhat/nightly/latest-RHEL-7/
Pungi:INFO: Added iptables.i686 (repo: pungi-repo) for iptables-devel.i686
Pungi:INFO: Added libnetfilter_conntrack.i686 (repo: pungi-repo) for iptables.i686
Pungi:INFO: Added libnfnetlink.i686 (repo: pungi-repo) for iptables.i686
Pungi:INFO: Added multilib package iptables.i686 (repo: pungi-repo) for package iptables.x86_64 (method: runtime)
Pungi:INFO: Checking deps of iptables.i686
Pungi:INFO: Found iptables.i686
Searching in /mnt/redhat/nightly/latest-Supp-7-RHEL-7/


But seems like glibc-common.x86_64 satisfies glibc.i686 requrements since depsolving doesn't claim any errors and glibc-common.i686 is not included.


Feel free to raise it to glibc packager (glibc component). But closing as works for me on 7.3/7.4

I can also confirm that we've never shipped a multilib package for glibc-common in RHEL-7

Lubos
Comment 6 Lubos Kocman 2017-01-12 10:48:52 EST
Restating the issue:

I didn't realize that multilib on glibc-common was not involved in the yum transaction (so it was my bad assumption)

Seems like you've installed newer glibc-common than the one which was required by given *78* version of glibc which had specific version requirement. Otherwise you can clearly see that 78 version is available from logs.

That does seem like problem on your side.



Lubos

Note You need to log in before you can comment on or make changes to this bug.