Bug 1280369 - production log littered with depraction warnings for 'ar_to_model_hash.rb:63' usage of 'numvcpus
production log littered with depraction warnings for 'ar_to_model_hash.rb:63'...
Status: CLOSED DUPLICATE of bug 1276666
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:07 EST by Thomas Hennessy
Modified: 2015-11-12 23:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 23:19:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-11-11 10:07:38 EST
Description of problem:production log littered with depraction warnings for 'ar_to_model_hash' usage of 'numvcpus'


Version-Release number of selected component (if applicable):
5.5.0.9-beta2

How reproducible: instantiate appliance in VMware environment and perform smartstate analysis


Steps to Reproduce:
1.
2.
3.

Actual results: many deprecation messages


Expected results:
no deprecation messages

Additional info:
Sample log lines:
=====
[----] W, [2015-11-09T07:45:37.350859 #13441:6fd998]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T07:45:49.584776 #715:d63990]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T07:46:09.307369 #13441:6fd998]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T07:46:29.202189 #715:d63990]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T08:45:18.104919 #715:d63990]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T08:45:28.113702 #715:d63990]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T08:45:36.155194 #13441:6fd998]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
[----] W, [2015-11-09T08:45:52.303672 #715:d63990]  WARN -- : DEPRECATION WARNING: numvcpus is deprecated and will be removed from ManageIQ D-release (cpu_sockets). (called from block in to_model_hash_attrs at /var/www/miq/vmdb/lib/extensions/ar_to_model_hash.rb:63)
=====
Comment 2 Dave Johnson 2015-11-12 23:19:08 EST

*** This bug has been marked as a duplicate of bug 1276666 ***

Note You need to log in before you can comment on or make changes to this bug.