Bug 1280373 - deprecation messages: /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42
deprecation messages: /var/www/miq/vmdb/app/models/ems_refresh/save_inventor...
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.6.0
Assigned To: Adam Grare
Dave Johnson
ems_refresh
:
: 1276666 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:13 EST by Thomas Hennessy
Modified: 2016-02-23 08:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:16:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-11-11 10:13:55 EST
Description of problem:thousands of deprecation messages from non-UI worker processes are littering the production log.  general message form is :"called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)"


Version-Release number of selected component (if applicable):
5.5.0.9-beta2

How reproducible: initiate smartstate scans and analysis from appliance with VMware provider


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Sample of production level depracation warning messages:
=====
[----] W, [2015-11-09T03:37:54.312659 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.410926 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.505765 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.595273 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.677448 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.802443 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:54.890845 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:55.018193 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
[----] W, [2015-11-09T03:37:55.106516 #5242:5c7998]  WARN -- : DEPRECATION WARNING: numvcpus= is deprecated and will be removed from ManageIQ D-release (cpu_sockets=). (called from save_inventory at /var/www/miq/vmdb/app/models/ems_refresh/save_inventory_helper.rb:42)
=====
Comment 2 Greg Blomquist 2016-02-19 16:05:40 EST
Adam, can you just validate that this doesn't happen anymore?

I think we cleaned all these up, but we may have missed a few.  Also, the bug indicates that it happens during smartstate, but I suspect you could reproduce this with a simple inventory collection.

If not, lean on Rich for some smart states.
Comment 3 Greg Blomquist 2016-02-19 16:24:36 EST
*** Bug 1276666 has been marked as a duplicate of this bug. ***
Comment 4 Adam Grare 2016-02-22 09:57:35 EST
Greg, I do not see this with current upstream doing an inventory collection.
Looking at the source at 5.5.0-beta2 we are setting the numvcpus property of hosts which would trigger that deprecation warning during an inventory refresh.

This appears to have been fixed by 15c9667fe7cd2c4ddb1d2c136c05b20d2b3a3762 which was added in 5.5.0-rc1.

Note You need to log in before you can comment on or make changes to this bug.