Bug 1280385 - attempt to read beyond end of the stream while parsing containers from openstack 7
attempt to read beyond end of the stream while parsing containers from openst...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks: 1290182
  Show dependency treegraph
 
Reported: 2015-11-11 10:44 EST by Felix Dewaleyne
Modified: 2016-02-08 09:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290182 (view as bug list)
Environment:
Last Closed: 2016-02-08 09:14:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Dewaleyne 2015-11-11 10:44:49 EST
Description of problem:
attempt to read beyond end of the stream while parsing containers from openstack 7

Version-Release number of selected component (if applicable):
5.4.3.1

How reproducible:
all the time in customer env.

Steps to Reproduce:
1. list the containers stored in an openstack 7 environemnt
2.
3.

Actual results:

[----] E, [2015-11-11T11:09:34.767015 #4263:e8bea8] ERROR -- : MIQ(EmsRefresh::Refreshers::OpenstackRefresher.refresh) EMS: [openstack beta], id: [101000000000010] Refresh failed
[----] E, [2015-11-11T11:09:34.767360 #4263:e8bea8] ERROR -- : [Excon::Errors::SocketError]: end of file reached (EOFError)  Method:[rescue in block in refresh]
[----] E, [2015-11-11T11:09:34.767544 #4263:e8bea8] ERROR -- : /opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/socket.rb:45:in `read_nonblock'
/opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/socket.rb:45:in `readline'
/opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/response.rb:53:in `parse'
/opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/middlewares/response_parser.rb:6:in `response_call'
/opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/connection.rb:372:in `response'
/opt/rh/cfme-gemset/gems/excon-0.45.4/lib/excon/connection.rb:236:in `request'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/connection.rb:81:in `request'
/opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/storage.rb:149:in `request'
/opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/requests/storage/get_containers.rb:21:in `get_containers'
/opt/rh/cfme-gemset/gems/fog-1.29.0/lib/fog/openstack/models/storage/directories.rb:11:in `all'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/collection.rb:113:in `lazy_load'
/opt/rh/cfme-gemset/gems/fog-core-1.32.1/lib/fog/core/collection.rb:17:in `length'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:250:in `detect_service'
/var/www/miq/lib/openstack/openstack_handle/handle.rb:229:in `detect_storage_service'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:29:in `initialize'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:9:in `new'
/var/www/miq/vmdb/app/models/ems_refresh/parsers/openstack.rb:9:in `ems_inv_to_hashes'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/openstack_refresher.rb:6:in `parse_inventory'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:20:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:8:in `each'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:8:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh/refreshers/base_refresher.rb:8:in `refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:80:in `block in refresh'
/var/www/miq/vmdb/app/models/ems_refresh.rb:78:in `each'
/var/www/miq/vmdb/app/models/ems_refresh.rb:78:in `refresh'
/var/www/miq/vmdb/app/models/miq_queue.rb:356:in `block in deliver'
/opt/rh/ruby200/root/usr/share/ruby/timeout.rb:66:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:352:in `deliver'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:107:in `deliver_queue_message'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:135:in `deliver_message'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:152:in `block in do_work'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:146:in `loop'
/var/www/miq/vmdb/lib/workers/queue_worker_base.rb:146:in `do_work'
/var/www/miq/vmdb/lib/workers/worker_base.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/lib/workers/worker_base.rb:320:in `loop'
/var/www/miq/vmdb/lib/workers/worker_base.rb:320:in `do_work_loop'
/var/www/miq/vmdb/lib/workers/worker_base.rb:141:in `run'
/var/www/miq/vmdb/lib/workers/worker_base.rb:122:in `start'
/var/www/miq/vmdb/lib/workers/worker_base.rb:23:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:3:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands/runner.rb:52:in `eval'
/opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands/runner.rb:52:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands.rb:64:in `require'
/opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands.rb:64:in `<top (required)>'
script/rails:6:in `require'
script/rails:6:in `<main>'


Expected results:
either extracting nothing because there are no elements or stopping at the last element.

Additional info:
currently waiting on swift list from the customer's openstack 7 env to confirm the situation.

Note You need to log in before you can comment on or make changes to this bug.