Bug 1280386 - Fatal error in production log when accessing catalog item on self_service UI
Fatal error in production log when accessing catalog item on self_service UI
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
medium Severity medium
: GA
: 5.6.0
Assigned To: Aparna Karve
Shveta
catalog:ssui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 10:48 EST by Josh Carter
Modified: 2016-07-12 14:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:15:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2015-11-11 10:48:13 EST
Description of problem:

When clicking to order a service the following error occurs in the log. 

[----] I, [2015-11-10T15:48:04.662423 #15017:6f598c]  INFO -- : Processing by ApiController#show as JSON
[----] I, [2015-11-10T15:48:04.662501 #15017:6f598c]  INFO -- :   Parameters: {"attributes"=>"picture,picture.image_href", "collection"=>"service_templates", "c_id"=>"22000000000001"}
[----] I, [2015-11-10T15:48:04.710548 #15017:6f598c]  INFO -- : Completed 200 OK in 48ms (Views: 0.3ms | ActiveRecord: 2.5ms)
[----] I, [2015-11-10T15:48:04.803074 #15008:56f98c]  INFO -- : Started GET "/components/font-awesome/fonts/fontawesome-webfont.woff2?v=4.3.0" for 127.0.0.1 at 2015-11-10 15:48:04 -0500
[----] F, [2015-11-10T15:48:04.804116 #15008:56f98c] FATAL -- :
ActionController::RoutingError (No route matches [GET] "/components/font-awesome/fonts/fontawesome-webfont.woff2"):
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/rack/logger.rb:38:in `call_app'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/rack/logger.rb:22:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.4) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.4) lib/rack/runtime.rb:18:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/activesupport/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
  rack (1.6.4) lib/rack/lock.rb:17:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/static.rb:116:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/actionpack/lib/action_dispatch/middleware/static.rb:116:in `call'
  rack (1.6.4) lib/rack/sendfile.rb:113:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/engine.rb:518:in `call'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/application.rb:165:in `call'
  rack (1.6.4) lib/rack/content_length.rb:15:in `call'
  thin (1.6.3) lib/thin/connection.rb:86:in `block in pre_process'
  thin (1.6.3) lib/thin/connection.rb:84:in `catch'
  thin (1.6.3) lib/thin/connection.rb:84:in `pre_process'
  thin (1.6.3) lib/thin/connection.rb:53:in `process'
  thin (1.6.3) lib/thin/connection.rb:39:in `receive_data'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run_machine'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run'
  thin (1.6.3) lib/thin/backends/base.rb:73:in `start'
  thin (1.6.3) lib/thin/server.rb:162:in `start'
  rack (1.6.4) lib/rack/handler/thin.rb:19:in `run'
  rack (1.6.4) lib/rack/server.rb:286:in `start'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/server.rb:80:in `start'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:80:in `block in server'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:75:in `tap'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:75:in `server'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  /opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:4:in `require'
  bin/rails:4:in `<main>'


Version-Release number of selected component (if applicable): 5.5 beta2


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Aparna Karve 2015-11-11 16:34:44 EST
Since I cannot reproduce this issue locally, can I get your appliance details?
Thanks.

Note You need to log in before you can comment on or make changes to this bug.