Bug 1280502 - Unable to launch torbrowser-launcher
Unable to launch torbrowser-launcher
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: torbrowser-launcher (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Robert Mayr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 17:39 EST by fedorix
Modified: 2016-08-27 06:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: torbrowser-launcher-0.2.6-1.fc24 torbrowser-launcher-0.2.6-1.fc23 torbrowser-launcher-0.2.6-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-21 19:22:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fedorix 2015-11-11 17:39:37 EST
Description of problem:
Unable to launch torbrowser-launcher

Version-Release number of selected component (if applicable):
[root@fedora23 fedokix]# uname -ar
Linux fedora23 4.2.5-300.fc23.x86_64 #1 SMP Tue Oct 27 04:29:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:


Steps to Reproduce:
1.install tor and torbrowser-launcher and  privoxy
2.activate tor service service  : tor start and service privoxy start
3.type on  cli torbrowser-launcher

Actual results:
[root@fedora23 fedokix]#  torbrowser-launcher                   
Tor Browser Launcher
By Micah Lee, licensed under MIT
version 0.2.1
https://github.com/micahflee/torbrowser-launcher
Updating over Tor
Checked for update within 24 hours, skipping
TBB is not installed, attempting to install 5.5a4-hardened
Downloading https://dist.torproject.org/torbrowser/5.5a4-hardened/tor-browser-linux64-5.5a4-hardened_fr.tar.xz.asc
Traceback (most recent call last):
  File "/usr/bin/torbrowser-launcher", line 30, in <module>
    torbrowser_launcher.main()
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/__init__.py", line 69, in main
    app = Launcher(common, url_list)
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/launcher.py", line 146, in __init__
    self.build_ui()
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/launcher.py", line 304, in build_ui
    self.start(None)
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/launcher.py", line 313, in start
    self.run_task()
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/launcher.py", line 338, in run_task
    self.download('signature', self.common.paths['sig_url'], self.common.paths['sig_file'])
  File "/usr/lib/python2.7/site-packages/torbrowser_launcher/launcher.py", line 485, in download
    None)
  File "/usr/lib64/python2.7/site-packages/twisted/web/client.py", line 1926, in request
    deferred = self._agent.request(method, uri, headers, bodyProducer)
  File "/usr/lib/python2.7/site-packages/txsocksx/http.py", line 43, in request
    return self._wrappedAgent.request(*a, **kw)
  File "/usr/lib64/python2.7/site-packages/twisted/web/client.py", line 1557, in request
    parsedURI = URI.fromBytes(uri)
  File "/usr/lib64/python2.7/site-packages/twisted/web/client.py", line 606, in fromBytes
    scheme, netloc, path, params, query, fragment = http.urlparse(uri)
  File "/usr/lib64/python2.7/site-packages/twisted/web/http.py", line 163, in urlparse
    raise TypeError("url must be bytes, not unicode")
TypeError: url must be bytes, not unicode


Expected results:
https://check.torproject.org

Additional info:
installed tbb ; activate service privoxy start
Comment 1 fedorix 2015-11-11 17:40:51 EST
root@fedora23 fedokix]# service tor status
Redirecting to /bin/systemctl status  tor.service
● tor.service - Anonymizing overlay network for TCP
   Loaded: loaded (/usr/lib/systemd/system/tor.service; disabled; vendor preset: disabled)
   Active: active (running) since mer. 2015-11-11 23:34:05 CET; 6min ago
  Process: 12191 ExecStartPre=/usr/bin/tor --runasdaemon 0 --defaults-torrc /usr/share/tor/defaults-torrc -f /etc/tor/torrc --verify-config (code=exited, status=0/SUCCESS)
 Main PID: 12193 (tor)
   CGroup: /system.slice/tor.service
           └─12193 /usr/bin/tor --runasdaemon 0 --defaults-torrc /usr/share/tor/defaults-torrc -f /etc/tor/torrc

nov. 11 23:34:04 fedora23 tor[12193]: Nov 11 23:34:04.668 [notice] Opening Socks listener on 127.0.0.1:9050
nov. 11 23:34:04 fedora23 Tor[12193]: Parsing GEOIP IPv6 file /usr/share/tor/geoip6.
nov. 11 23:34:04 fedora23 Tor[12193]: Bootstrapped 0%: Starting
nov. 11 23:34:05 fedora23 Tor[12193]: Bootstrapped 80%: Connecting to the Tor network
nov. 11 23:34:05 fedora23 Tor[12193]: Signaled readiness to systemd
nov. 11 23:34:05 fedora23 systemd[1]: Started Anonymizing overlay network for TCP.
nov. 11 23:34:06 fedora23 Tor[12193]: Bootstrapped 85%: Finishing handshake with first hop
nov. 11 23:34:06 fedora23 Tor[12193]: Bootstrapped 90%: Establishing a Tor circuit
nov. 11 23:34:06 fedora23 Tor[12193]: Tor has successfully opened a circuit. Looks like client functionality is working.
nov. 11 23:34:06 fedora23 Tor[12193]: Bootstrapped 100%: Done
Comment 2 Jamie Nguyen 2015-11-12 02:32:04 EST
This doesn't appear to be any problem for the Tor package. The problem is with "torbrowser-launcher". Reassigning.
Comment 3 Fedora Update System 2016-08-11 17:30:56 EDT
torbrowser-launcher-0.2.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-196bdd506a
Comment 4 Fedora Update System 2016-08-11 17:31:32 EDT
torbrowser-launcher-0.2.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc2a70c58a
Comment 5 Fedora Update System 2016-08-11 17:32:59 EDT
torbrowser-launcher-0.2.6-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f19d0e541
Comment 6 Fedora Update System 2016-08-12 10:27:50 EDT
torbrowser-launcher-0.2.6-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f19d0e541
Comment 7 Fedora Update System 2016-08-12 16:52:38 EDT
torbrowser-launcher-0.2.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-196bdd506a
Comment 8 Fedora Update System 2016-08-12 16:52:41 EDT
torbrowser-launcher-0.2.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc2a70c58a
Comment 9 Fedora Update System 2016-08-21 19:22:53 EDT
torbrowser-launcher-0.2.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-08-21 21:20:34 EDT
torbrowser-launcher-0.2.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-08-27 06:38:43 EDT
torbrowser-launcher-0.2.6-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.