Bug 128076 - error: %post(pango-1.2.5-2.0) scriptlet failed
Summary: error: %post(pango-1.2.5-2.0) scriptlet failed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: pango   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-16 23:55 UTC by Jay Turner
Modified: 2015-01-08 00:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 03:33:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2004:488 high SHIPPED_LIVE Updated gtk2, pango and librsvg2 packages 2004-12-20 05:00:00 UTC

Description Jay Turner 2004-07-16 23:55:05 UTC
Description of problem:
Getting the following when attempting to install the i386 package
alongside the x86_64 package:

Installing pango-1.2.5-2.0.i386.
/var/tmp/rpm-tmp.23539: line 2: /usr/bin/pango-querymodules: No such
file or directory
error: %post(pango-1.2.5-2.0) scriptlet failed, exit status 127

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Owen Taylor 2004-07-17 14:26:46 UTC
This known and expected - FC3 has pango and gtk2 hacked
up to parallel install ... RHEL3 U3 doesn't.

Comment 2 Jay Turner 2004-08-10 18:01:04 UTC
The root cause of this issue is that the new RPM is always preferring
ELF64 binaries over ELF32 ones.  Net result is that during the
installation of the 32-bit package, RPM choses to skip installing the
ELF32 binaries, therefore they aren't present to run during the
post-install scriptlets.  See #128072 for more details.

Comment 3 Mike McLean 2004-08-30 18:08:27 UTC
This is still happening with RHEL3-U3-re0828.0-x86_64

Comment 5 Owen Taylor 2004-08-30 19:11:55 UTC
32-bit Pango is not supposed to be pulled in because you should have
a 64-bit openoffice.org-style-gnome with U3.

On the installed system, can you do:

 $ rpm -q --requires openoffice.org
 $ rpm -q --requires openoffice.org-style


Comment 6 Mike McLean 2004-09-02 19:53:49 UTC
I think 32bit pango is pulled in because something that requires it is
listed as multilib.  

Comment 7 Owen Taylor 2004-09-09 20:37:26 UTC
Nothing much I can do on this. Someone who understands comps
would have to take a look. multilib pango is tentatively planned
for U4, so it may not matter at this point.


Comment 8 Bill Nottingham 2004-09-09 20:39:28 UTC
It's pulled in by 32-bit mozilla.

Comment 9 John Flanagan 2004-12-21 03:33:45 UTC
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-488.html



Note You need to log in before you can comment on or make changes to this bug.