Bug 128091 - sigishandled() misbehaviour due to bug in parse_sigset_t()
Summary: sigishandled() misbehaviour due to bug in parse_sigset_t()
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: strace   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-17 15:44 UTC by Dmitry V. Levin
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 02:02:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace-4.5.5-alt-parse_sigset.patch (560 bytes, patch)
2004-07-17 15:45 UTC, Dmitry V. Levin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:131 normal SHIPPED_LIVE strace bug fix update 2005-05-19 04:00:00 UTC

Description Dmitry V. Levin 2004-07-17 15:44:26 UTC
When traced process receives signal which will be handled, strace may
decide that process is going to die and will detach from this process.

It happens because sigishandled() sometimes incorrectly returns 0 due
to hex string parser bug in parse_sigset_t().

Comment 1 Dmitry V. Levin 2004-07-17 15:45:49 UTC
Created attachment 102000 [details]
strace-4.5.5-alt-parse_sigset.patch

Proposed patch.

Comment 2 Roland McGrath 2004-08-31 07:01:03 UTC
Fix in upstream.

Comment 3 Roland McGrath 2004-09-01 02:02:06 UTC
4.5.7-2 is in rawhide.  I'll make an FC2 update release in a few days.

Comment 4 Tim Powers 2005-05-19 21:09:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-131.html



Note You need to log in before you can comment on or make changes to this bug.