Bug 128123 - cyrus-sasl 2.1.19 is released
Summary: cyrus-sasl 2.1.19 is released
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-sasl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL: http://ftp.andrew.cmu.edu/pub/cyrus-m...
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-18 20:30 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.1.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-07 11:20:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-07-18 20:30:08 UTC
Description of problem:
cyrus-sasl 2.1.19 was released at July, 17 2004 (yesterday) - and 
Fedora Development only has the older 2.1.18.

2.1.19 fixes potential buffer overflows and contains lots of fixes. 
More you can take from the changelog.

Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.18-5

Actual results:
A simple upgrade - with changing version numbers in the spec file - 
worked very well for me.

Expected results:
Upgrade to 2.1.19 ;-)

Comment 1 Robert Scheck 2004-07-18 21:01:52 UTC
Some users reported problems with rebuilding cyrus-sasl 2.1.19 at 
Fedora Development and suggest the following fix:

perl -pi -e 's/dbconverter-1.5.c/dbconverter-1.5.9.c/' cyrus-sasl-2.1.19/cyrus-sasl-1.5.28/utils/Makefile
perl -pi -e 's/dbconverter-1.5.\$/dbconverter-1.5.9.\$/' cyrus-sasl-2.1.19/cyrus-sasl-1.5.28/utils/Makefile

Thanks to Marco for that workaround! :) For me it seems as an 
automake/autoconf problem, but I'm not able to reproduce the problem:

make[2]: Entering directory `/usr/src/redhat/BUILD/cyrus-sasl-2.1.19/cyrus-sasl-1.5.28/utils'
make[2]: *** No rule to make target `dbconverter-1.5.c', needed by `dbconverter-1.5.o'.  Stop.

Nalin, maybe you'll hit also to that problem, if you make the 
rebuild for Fedora Development - I currently don't have an up2date 
Fedora Core Development system.

Comment 2 Robert Scheck 2004-08-13 02:06:14 UTC
We should implicitly add the following requirement, even if cyrus-
sasl is linked against the internal unthreaded db4. After this we 
would have the same (correct) requirement behaviour in this part 
like the pam package:

"Requires: db4 = %{db_version}"

BTW, cyrus-sasl 1.5.28 isn't really happy with automake 1.9.1 and 
the other way round, because we get lots of harmless but stupid 
warnings, if someone has too much time, he can fix it... ;-)

Even more critical is the problem, that I can't rebuild cyrus-sasl 
2.1.19 against the unthreaded db4 4.2.52 without having an error:

--- snipp ---
gcc -Wall -W -I/usr/kerberos/include -I/include -O2 -g -march=i386 -mcpu=i686 -fPIC -I/usr/include/mysql -o dbconverter-2 dbconverter_2-dbconverter-2.o  -L/usr/kerberos/lib -L/lib -L/usr/lib/mysql ../sasldb/.libs/libsasldb.a ../lib/.libs/libsasl2.a -L/usr/src/redhat/BUILD/cyrus-sasl-2.1.19/db-instroot/lib -ldl -lcrypto -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -ldb-4.2 /usr/lib/libgdbm.so -lresolv -lcrypt
../sasldb/.libs/libsasldb.a(db_berkeley.o)(.text+0x70): In function `berkeleydb_open':
../../sasldb/db_berkeley.c:85: undefined reference to `db_create_cyrus_sasl_sasldb_rh'
../sasldb/.libs/libsasldb.a(db_berkeley.o)(.text+0x8b):../../sasldb/db_berkeley.c:102: undefined reference to `db_strerror_cyrus_sasl_sasldb_rh'
--- snapp ---

With cyrus-sasl 2.1.18-5 the rebuild worked fine...

Comment 3 Robert Scheck 2004-08-20 15:16:57 UTC
Okay, cyrus-sasl 2.1.19-1 doesn't have the rebuilding problems I had.

But I'm still missing the dependence to db4 = %{db_version} - even, if
db4 is bundled, because pam has the same behaviour, even if no external
db4 is also needed.

The missing build requirement is EasyFix now, marking it.

Comment 4 Robert Scheck 2004-11-07 11:20:56 UTC
Closing, so 2.1.20-1 is already pushed to Rawhide, separating my open 
problem/enhancement to bug #138281.


Note You need to log in before you can comment on or make changes to this bug.