Bug 1281263 - net-create help missing info for 'router:external'
net-create help missing info for 'router:external'
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutronclient (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: John Schwarz
Ofer Blaut
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 03:04 EST by yfried
Modified: 2016-04-26 12:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 12:12:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1237820 None None None 2016-01-07 08:54 EST
Launchpad 1515199 None None None Never
OpenStack gerrit 137279 None None None 2016-01-07 08:46 EST

  None (edit)
Description yfried 2015-11-12 03:04:21 EST
neutron --version
2.4.0

usage: neutron net-create [-h] [-f {shell,table,value}] [-c COLUMN]
                          [--max-width <integer>] [--prefix PREFIX]
                          [--request-format {json,xml}]
                          [--tenant-id TENANT_ID] [--admin-state-down]
                          [--shared] [--provider:network_type <network_type>]
                          [--provider:physical_network <physical_network_name>]
                          [--provider:segmentation_id <segmentation_id>]
                          [--vlan-transparent {True,False}]
                          NAME

Create a network for a given tenant.

positional arguments:
  NAME Name of network to create.

optional arguments:
  -h, --help show this help message and exit
  --request-format {json,xml}
                        The XML or JSON request format.
  --tenant-id TENANT_ID
                        The owner tenant ID.
  --admin-state-down Set admin state up to false.
  --shared Set the network as shared.
  --provider:network_type <network_type>
                        The physical mechanism by which the virtual network is
                        implemented.
  --provider:physical_network <physical_network_name>
                        Name of the physical network over which the virtual
                        network is implemented.
  --provider:segmentation_id <segmentation_id>
                        VLAN ID for VLAN networks or tunnel-id for GRE/VXLAN
                        networks.
  --vlan-transparent {True,False}
                        Create a vlan transparent network.

output formatters:
  output formatter options

  -f {shell,table,value}, --format {shell,table,value}
                        the output format, defaults to table
  -c COLUMN, --column COLUMN
                        specify the column(s) to include, can be repeated

table formatter:
  --max-width <integer>
                        Maximum display width, 0 to disable

shell formatter:
  a format a UNIX shell can parse (variable="value")

  --prefix PREFIX add a prefix to all variable names
Comment 2 John Schwarz 2016-01-07 08:51:56 EST
So this is a somewhat-duplicate bugzilla of [1]. Long story short is that nmagnezi tried to fix this issue, but the fix was soon reverted because it breaks backward compatibility, since the original addition of router:external was somewhat of a special case (it used the extra argument mechanism of argparse, unlike the rest of the arguments) and further attempts to fix this issue are still ongoing upstream [2]. See [3] on the ongoing upstream discussions about this issue.

TL;DR: The current implementation reduces user experience, upstream is aware, they are trying to fix this themselves.

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=1221327
[2]: https://review.openstack.org/#/c/137279/
[3]: https://bugs.launchpad.net/python-neutronclient/+bug/1237820/comments/6
Comment 3 Assaf Muller 2016-01-12 12:12:57 EST
No need to track this downstream.

Note You need to log in before you can comment on or make changes to this bug.