Bug 128130 - ALSA output plugin modifications aren't 64-bit clean
Summary: ALSA output plugin modifications aren't 64-bit clean
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libao   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-19 04:10 UTC by Nicholas Miell
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 0.8.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 21:43:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix 64bit problems (563 bytes, patch)
2004-07-19 04:13 UTC, Nicholas Miell
no flags Details | Diff

Description Nicholas Miell 2004-07-19 04:10:24 UTC
The RH patch to libao that makes the alsa09 output plugin work with
ALSA 1.0 is not 64-bit clean, resulting in a division by zero at
plugin init time.

Patch attached.

Comment 1 Nicholas Miell 2004-07-19 04:13:09 UTC
Created attachment 102022 [details]
Fix 64bit problems

This patch needs to be applied after the current libao-0.8.4-alsa10.patch

Comment 2 Nicholas Miell 2004-07-19 04:18:41 UTC
You should probably just grab libao 0.8.5 from upstream, though.

Comment 3 Colin Walters 2004-09-15 21:43:19 UTC
This should be fixed now then since we updated to 0.8.5, thanks.


Note You need to log in before you can comment on or make changes to this bug.