Bug 1281310 - unity-plugin is not built
unity-plugin is not built
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: strongswan (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Šimerda (pavlix)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 04:48 EST by Thomas Antepoth
Modified: 2016-07-19 14:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:27:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Antepoth 2015-11-12 04:48:35 EST
Description of problem:

For split-networking to Cisco access concentrators using IKEv1 the unity plugin is needed.
The upstream description of the unity plugin is here:

https://wiki.strongswan.org/projects/strongswan/wiki/UnityPlugin


Version-Release number of selected component (if applicable):

5.3.2


How reproducible:

There is no /etc/strongswan/strongswan.d/charon/unity.conf where the unity plugin can be configured as well as there is no /usr/lib/strongswan/plugins/libstrongswan-unity.so


Expected results:

A /etc/strongswan/strongswan.d/charon/unity.conf where the unity plugin can be configured as well as a /usr/lib/strongswan/plugins/libstrongswan-unity.so

===


==


Additional info:
This plugin is currently not included in the FC22 build of strongswan because the "--enable-unity" configure directive is missing in build section of the spec file of the strongswan srpm.

After adding this directive as well as the new file libstrongswan-unity.so the unity plugin is built into the rpm and can be used after installation.
Comment 1 Pavel Šimerda (pavlix) 2016-07-13 10:16:33 EDT
Good idea.
Comment 2 Fedora End Of Life 2016-07-19 14:27:51 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.