Bug 1281340 - config file comparison event detail page is missing link to the diff
config file comparison event detail page is missing link to the diff
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
570
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Grant Gainey
Radovan Drazny
:
: 1290773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 05:45 EST by Jan Hutař
Modified: 2016-01-11 10:19 EST (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-java-2.3.8-121-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 10:19:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Same steps performed on Satellite 5.6.0 and 5.7.0 and result of config diff event page (5.7.0 is missing the link) (79.10 KB, image/png)
2015-11-12 05:45 EST, Jan Hutař
no flags Details
Screenshot of the diff event details page before and after update. (36.71 KB, image/png)
2015-12-17 08:57 EST, Radovan Drazny
no flags Details

  None (edit)
Description Jan Hutař 2015-11-12 05:45:32 EST
Created attachment 1093128 [details]
Same steps performed on Satellite 5.6.0 and 5.7.0 and result of config diff event page (5.7.0 is missing the link)

Description of problem:
When configuration file comparison finds a difference, event detail page is missing link to the diff.


Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-117.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Create config channel, create file in it, ensure the client have
   `rhn-actions-control --enable-all`, deploy that file on the client,
   change that deployed file on the client
2. Schedule config file diff:
   Systems -> <client> -> Configuration -> Compare Files
3. Run `rhn_check` on the client so the diff is executed
4. Check if we have link to the diff on the event page
   Systems -> <client> -> Events -> History -> <event>


Actual results:
No link to the diff, although when I guess "acrid" parametr, diff displays nicely: https://<fqdn>/rhn/systems/details/configuration/ViewDiffResult.do?sid=<sid>&acrid=...

See the attached screenshot.


Expected results:
Link to the diff of whats on the system and what in the config channel should be present.


Additional info:
This was noticed by Vivek Dhande <vdhande@redhat.com> - thanks!

This is a regression against 5.6.0.
Comment 1 Grant Gainey 2015-11-17 14:49:33 EST
Fixed in SW under https://bugzilla.redhat.com/show_bug.cgi?id=1205108. The following commit fixes the problem:

spacewalk.git: e87b3e10e507a0b169dff6d0dd72de9894b3ac90
Comment 4 Tomas Lestach 2015-12-11 10:57:23 EST
*** Bug 1290773 has been marked as a duplicate of this bug. ***
Comment 5 Radovan Drazny 2015-12-17 08:55:36 EST
Reproduced on spacewalk-java-2.3.8-120.el6sat.noarch using the reproducer from comment #1, with the same result - no link to file difference present. 

Updated to spacewalk-java-2.3.8-123.el6sat.noarch, modified the managed file on a registered station, and scheduled a new diff run. I have run rhn_check on the registered station, and checked the event log on Satellite server. The link to file difference is now present. See the attached screenshot.

VERIFIED
Comment 6 Radovan Drazny 2015-12-17 08:57 EST
Created attachment 1106731 [details]
Screenshot of the diff event details page before and after update.
Comment 11 errata-xmlrpc 2016-01-11 10:19:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0023.html

Note You need to log in before you can comment on or make changes to this bug.