Bug 128141 - GFS spec file kernel_src path should be different
Summary: GFS spec file kernel_src path should be different
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-19 09:36 UTC by Jos Vos
Modified: 2010-01-12 02:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 16:55:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2004-07-19 09:36:52 UTC
Description of problem:
In the gfs-build.spec file, the 3rd line of the BuildSistina routine
contains:

  kernel_src=/lib/modules/%{kernel_version}$flavor/build

This line requires to have all flavours of the kernel (smp, hugemem,
etc.) installed on the build system, only to have this particular
symlink installed, while the following line would not have this
limitation and works identically:

  kernel_src=/usr/src/linux-%{kernel_version}

Version-Release number of selected component (if applicable):
GFS-6.0.0-1.2.

Comment 1 Jos Vos 2004-07-20 09:34:08 UTC
Note: problem also applies to GFS-6.0.0-7.


Comment 2 Jonathan Earl Brassow 2004-07-20 17:36:51 UTC
Yes, since the kernel tree is copied, an mrproper is done, and the appropriate 
config file is selected, the above advice would work while allowing fewer 
steps.

This has been fixed in GFS > 6.0.0-7

Comment 3 Jos Vos 2004-07-20 17:45:37 UTC
Well, not really fewer steps, fewer dependencies: the symlinks in
/lib/modules of all kernel flavors (within the same version-release)
point the the exact same tree in /usr/src ;-).


Note You need to log in before you can comment on or make changes to this bug.