Bug 1281452 - Several configuration files are missing in dirtyconf directory
Several configuration files are missing in dirtyconf directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-el6toel7 (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: pstodulk
Tereza Cerna
: Extras
Depends On:
Blocks: 1335038
  Show dependency treegraph
 
Reported: 2015-11-12 09:52 EST by Tereza Cerna
Modified: 2016-11-04 05:00 EDT (History)
8 users (show)

See Also:
Fixed In Version: preupgrade-assistant-el6toel7-0.6.59-3.el6
Doc Type: Bug Fix
Doc Text:
Before this fix, the Preupgrade Assistant incorrectly left some untracked configuration files intact, although these were on a list of files which should have been backed up. This no longer occurs with a new Preupgrade Assistant version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 05:00:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tereza Cerna 2015-11-12 09:52:54 EST
Several configuration files are missing in /root/preupgrade/dirtyconf directory. Files are in $PATH/noverifycfg, not in $PATH/verified_blacklist and exist in system. Problem is that this files are owned by more packages.

PATH="/usr/share/preupgrade/RHEL6_7/backup/NoverifyConfigs"

List of concerned files:
/etc/crypttab
/etc/gai.conf
/etc/selinux/targeted/modules/active/seusers.final
/etc/selinux/targeted/modules/active/users_extra
/etc/selinux/targeted/seusers

See log from test case for /etc/crypttab:
:: [   LOG    ] :: File /etc/crypttab exists on this system
:: [   PASS   ] :: File 'cleanconfList' should not contain '/etc/crypttab' 
:: [   FAIL   ] :: File 'dirtyconfList' should contain '/etc/crypttab'
Comment 1 Tereza Cerna 2015-11-12 10:00:28 EST
Affected packages:
  preupgrade-assistant-2.0.3-12.el6.x86_64
  preupgrade-assistant-contents-0.6.33-1.el6.noarch
  redhat-upgrade-tool-0.7.41-1.el6.noarch
Comment 8 Tereza Cerna 2016-10-11 08:10:51 EDT
Failed QA.

There are three untracked file which are not saved in cleanconf, neither in dirtyconf

Untracked files:
  /etc/selinux/targeted/modules/active/seusers.final
  /etc/selinux/targeted/modules/active/users_extra
  /etc/selinux/targeted/seusers
Comment 9 pstodulk 2016-10-11 18:49:35 EDT
Fixed. It was caused mainly by unexpanded globs and unread last lines of the input files. Now it should be completely OK.

This was resolved by patch file. Changes in upstream will be merged next cycle.
Comment 13 errata-xmlrpc 2016-11-04 05:00:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2618.html

Note You need to log in before you can comment on or make changes to this bug.