Bug 1281571 - [RFE][nova]: Deprecate service management in nova-manage
[RFE][nova]: Deprecate service management in nova-manage
Status: CLOSED DUPLICATE of bug 1281572
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity low
: Upstream M1
: 9.0 (Mitaka)
Assigned To: Eoghan Glynn
nlevinki
https://blueprints.launchpad.net/nova...
upstream_milestone_mitaka-1 upstream_...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 15:05 EST by Stephen Gordon
Modified: 2015-12-10 14:56 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 13:38:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2015-11-12 15:05:52 EST
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/deprecate-service-management-in-nova-manage.

Description:

The service command of nova-manage tool provides duplicated functionality
with the nova REST API.

The novaclient already has the following service commands:

service-disable   Disable the service.
service-enable    Enable the service.
service-list      Show a list of all running services.
host-describe     Describe a specific host

This covers what nova-manage service was providing so let's
deprecate the legacy nova-manage subcommand and mark it for
removal in the N release.

Specification URL (additional information):

None
Comment 2 Jon Schlueter 2015-11-30 13:38:51 EST

*** This bug has been marked as a duplicate of bug 1281572 ***

Note You need to log in before you can comment on or make changes to this bug.