Bug 1281572 - [RFE][nova]: Deprecate service management in nova-manage
[RFE][nova]: Deprecate service management in nova-manage
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
low Severity low
: ga
: 9.0 (Mitaka)
Assigned To: Eoghan Glynn
Prasanth Anbalagan
https://blueprints.launchpad.net/nova...
upstream_milestone_mitaka-1 upstream_...
: FutureFeature, TestOnly, ZStream
: 1281571 (view as bug list)
Depends On:
Blocks: 1281573 1335634
  Show dependency treegraph
 
Reported: 2015-11-12 15:07 EST by Stephen Gordon
Modified: 2016-08-24 08:57 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-nova-13.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 08:57:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 240858 None None None Never

  None (edit)
Description Stephen Gordon 2015-11-12 15:07:50 EST
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/deprecate-service-management-in-nova-manage.

Description:

The service command of nova-manage tool provides duplicated functionality
with the nova REST API.

The novaclient already has the following service commands:

service-disable   Disable the service.
service-enable    Enable the service.
service-list      Show a list of all running services.
host-describe     Describe a specific host

This covers what nova-manage service was providing so let's
deprecate the legacy nova-manage subcommand and mark it for
removal in the N release.

Specification URL (additional information):

None
Comment 2 Jon Schlueter 2015-11-30 13:38:51 EST
*** Bug 1281571 has been marked as a duplicate of this bug. ***
Comment 6 Mike McCune 2016-03-28 18:33:16 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 Prasanth Anbalagan 2016-08-18 10:51:01 EDT
Verified as follows - Command is deprecated as expected.

***********
VERSION
***********

[root@serverX]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-cert.noarch           1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-common.noarch         1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-compute.noarch        1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-conductor.noarch      1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-console.noarch        1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-novncproxy.noarch     1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
openstack-nova-scheduler.noarch      1:13.1.1-2.el7ost       @rhelosp-9.0-puddle
[root@serverX]# 

******
LOGS
******
[root@serverX]#  nova-manage service -h
Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
usage: nova-manage service [-h] {describe_resource,disable,enable,list} ...

DEPRECATED: Use the nova service-* commands from python-novaclient instead or
the os-services REST resource. The service subcommand will be removed in the
14.0 release.

positional arguments:
  {describe_resource,disable,enable,list}

optional arguments:
  -h, --help            show this help message and exit
[root@serverX]#
Comment 12 errata-xmlrpc 2016-08-24 08:57:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1758.html

Note You need to log in before you can comment on or make changes to this bug.