Bug 1281614 - Wrong memory detected for discovered SuperMicro system
Wrong memory detected for discovered SuperMicro system
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-discoverd (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity medium
: ---
: 7.0 (Kilo)
Assigned To: RHOS Maint
Raviv Bar-Tal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 18:24 EST by Thom Carlin
Modified: 2016-12-12 10:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-12 10:16:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-11-12 18:24:39 EST
Description of problem:

If a Supermicro is chosen as a node for RHCS-I/Triple-O Node, the memory is incorrectly reported as MB instead of GB

Version-Release number of selected component (if applicable):

1.1.0-7.el7ost

How reproducible:

100%

Steps to Reproduce:
1. Install RHCS-I 
2. Install Triple-O
3. In Deployment, register a Supermicro node

Actual results:

Memory: 32 MB

Expected results:

Memory: 32 GB

Additional info:

ironic-discoverd-ramdisk is using: 
dmidecode --type memory | grep Size | awk '{ print $2; }' | grep -E '[0-9]+'

This works for Dell because it assumes MB:
dmidecode --type memory | grep Size
	Size: 8192 MB
	Size: 8192 MB
	Size: 8192 MB
	Size: 8192 MB

but not so well for SuperMicro:
 dmidecode --type memory | grep Size
	Size: 32 GB
	Size: No Module Installed
	Size: No Module Installed
	Size: No Module Installed
Comment 2 Thom Carlin 2016-01-28 09:03:17 EST
will propagate through to nova flavor-list
Comment 3 Thom Carlin 2016-01-28 10:49:13 EST
Workaround: 
mysql
use ironic;
update nodes SET properties='<full properties with proper memory size>' where id=<node_id>;
Comment 4 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Dmitry Tantsur 2016-07-08 08:44:36 EDT
Hi! What's the release version this bug is reported against? I'm pretty sure we got it fixed either in Mitaka (OSP9) or Newton (OSP10).
Comment 7 Thom Carlin 2016-07-08 08:45:37 EDT
Kilo (OSP7)
Comment 8 Dmitry Tantsur 2016-07-08 11:13:11 EDT
Thanks, fixing the flags and the project then.
Comment 9 Dmitry Tantsur 2016-12-12 10:16:39 EST
Hi! I'm sorry, but the OSP7 version has diverged so much from the current code, and is so difficult to update in a safe fashion, that we decided not to fix this bug. Please update nodes' memory_mb manually as a workaround. Thanks for understanding!

Note You need to log in before you can comment on or make changes to this bug.