Bug 1281616 - Kernel warning in intel graphics driver
Kernel warning in intel graphics driver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 18:39 EST by Bojan Smojver
Modified: 2015-11-13 09:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 08:15:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2015-11-12 18:39:00 EST
Description of problem:
ABRT gave me a report about this:

[ 9967.456896] ------------[ cut here ]------------
[ 9967.456936] WARNING: CPU: 0 PID: 0 at drivers/gpu/drm/i915/intel_display.c:11100 intel_check_page_flip+0xea/0x100 [i915]()
[ 9967.456938] Kicking stuck page flip: queued at 411338, now 411342
[ 9967.456939] Modules linked in: rfcomm fuse cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge ebtable_nat ebtable_filter ebtables ip6table_raw ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_filter ip6_tables iptable_raw iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security bnep intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm_intel kvm arc4 iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek crct10dif_pclmul crc32_pclmul snd_hda_codec_generic iwlmvm crc32c_intel vfat fat snd_hda_intel snd_hda_codec mac80211 snd_hda_core uvcvideo snd_hwdep
[ 9967.456986]  snd_seq videobuf2_vmalloc videobuf2_core videobuf2_memops v4l2_common snd_seq_device videodev iwlwifi btusb snd_pcm btrtl btbcm cfg80211 btintel i2c_i801 media joydev bluetooth thinkpad_acpi rtsx_pci_ms mei_me memstick snd_timer mei snd shpchp lpc_ich soundcore wmi tpm_tis rfkill tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc 8021q garp stp llc mrp i915 rtsx_pci_sdmmc mmc_core e1000e i2c_algo_bit drm_kms_helper serio_raw drm ptp rtsx_pci pps_core video
[ 9967.457014] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G        W       4.2.6-300.fc23.x86_64 #1
[ 9967.457015] Hardware name: LENOVO 20BXCTO1WW/20BXCTO1WW, BIOS JBET53WW (1.18 ) 09/14/2015
[ 9967.457017]  0000000000000000 68a3ebb6ad699356 ffff88023dc03d68 ffffffff817729ea
[ 9967.457019]  0000000000000000 ffff88023dc03dc0 ffff88023dc03da8 ffffffff8109e4b6
[ 9967.457021]  ffff88023dc03dd8 ffff8800b5607800 ffff8800b57e0000 0000000000000000
[ 9967.457023] Call Trace:
[ 9967.457025]  <IRQ>  [<ffffffff817729ea>] dump_stack+0x45/0x57
[ 9967.457032]  [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
[ 9967.457034]  [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
[ 9967.457049]  [<ffffffffa01a162a>] intel_check_page_flip+0xea/0x100 [i915]
[ 9967.457061]  [<ffffffffa016c6b9>] gen8_irq_handler+0x369/0x560 [i915]
[ 9967.457064]  [<ffffffff810f5ff4>] handle_irq_event_percpu+0x74/0x180
[ 9967.457066]  [<ffffffff810f6130>] handle_irq_event+0x30/0x60
[ 9967.457068]  [<ffffffff810f944f>] handle_edge_irq+0x6f/0x130
[ 9967.457070]  [<ffffffff81016e62>] handle_irq+0x72/0x120
[ 9967.457073]  [<ffffffff810bd67a>] ? atomic_notifier_call_chain+0x1a/0x20
[ 9967.457076]  [<ffffffff8177c01f>] do_IRQ+0x4f/0xe0
[ 9967.457078]  [<ffffffff81779f2b>] common_interrupt+0x6b/0x6b
[ 9967.457079]  <EOI>  [<ffffffff81108abf>] ? hrtimer_start_range_ns+0x1bf/0x3b0
[ 9967.457085]  [<ffffffff81616780>] ? cpuidle_enter_state+0x130/0x270
[ 9967.457087]  [<ffffffff8161675b>] ? cpuidle_enter_state+0x10b/0x270
[ 9967.457089]  [<ffffffff816168f7>] cpuidle_enter+0x17/0x20
[ 9967.457091]  [<ffffffff810dfcf2>] call_cpuidle+0x32/0x60
[ 9967.457093]  [<ffffffff816168d3>] ? cpuidle_select+0x13/0x20
[ 9967.457095]  [<ffffffff810dff88>] cpu_startup_entry+0x268/0x320
[ 9967.457097]  [<ffffffff8176912c>] rest_init+0x7c/0x80
[ 9967.457100]  [<ffffffff81d5702d>] start_kernel+0x49d/0x4be
[ 9967.457103]  [<ffffffff81d56120>] ? early_idt_handler_array+0x120/0x120
[ 9967.457105]  [<ffffffff81d56339>] x86_64_start_reservations+0x2a/0x2c
[ 9967.457106]  [<ffffffff81d56485>] x86_64_start_kernel+0x14a/0x16d
[ 9967.457108] ---[ end trace 4e962173ff9459da ]---

And claimed that this cannot be reported, because my kernel is tainted, which it is not. I have no proprietary modules loaded. The only proprietary piece of software on this Fedora installation is Citrix Receiver, which provides no kernel modules.

Version-Release number of selected component (if applicable):
kernel-4.2.6-300.fc23.x86_64

How reproducible:
Not quite sure. Seen this for the first time when testing this kernel.

Steps to Reproduce:
1. Not sure. I was away from the machine when it happened.

Actual results:
Warnings being thrown in dmesg. Kernel reported as tainted.

Expected results:
Never seen this before 4.2.6.

Additional info:
Comment 1 Laura Abbott 2015-11-12 19:53:20 EST
Tainted has other meanings besides proprietary modules see https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/kernel/panic.c#n243

[ 9967.457014] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G        W       4.2.6-300.fc23.x86_64 #1

The W there indicates there were other warnings before this one which is a valid taint. Please look in the dmesg for the first warning.
Comment 2 Bojan Smojver 2015-11-12 20:03:56 EST
Right. OK, didn't know about that. The first warning is already reported a few different bugs:

[    0.468347] ------------[ cut here ]------------
[    0.468354] WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
[    0.468358] Info: mapping multiple BARs. Your kernel is fine.
[    0.468360] Modules linked in:

[    0.468367] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.2.6-300.fc23.x86_64 #1
[    0.468371] Hardware name: LENOVO 20BXCTO1WW/20BXCTO1WW, BIOS JBET53WW (1.18 ) 09/14/2015
[    0.468376]  0000000000000000 00000000293d6a8a ffff88023429ba78 ffffffff817729ea
[    0.468383]  0000000000000000 ffff88023429bad0 ffff88023429bab8 ffffffff8109e4b6
[    0.468389]  ffff88023429bae8 00000000fed10000 ffffc90000cc0000 0000000000006000
[    0.468395] Call Trace:
[    0.468400]  [<ffffffff817729ea>] dump_stack+0x45/0x57
[    0.468406]  [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
[    0.468410]  [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
[    0.468414]  [<ffffffff81065b95>] __ioremap_caller+0x2c5/0x380
[    0.468419]  [<ffffffff81065c67>] ioremap_nocache+0x17/0x20
[    0.468424]  [<ffffffff81039c89>] snb_uncore_imc_init_box+0x79/0xb0
[    0.468434]  [<ffffffff81038434>] uncore_pci_probe+0xd4/0x1a0
[    0.468439]  [<ffffffff813e62a5>] local_pci_probe+0x45/0xa0
[    0.468443]  [<ffffffff8129a70d>] ? sysfs_do_create_link_sd.isra.2+0x6d/0xb0
[    0.468448]  [<ffffffff813e749d>] pci_device_probe+0xed/0x140
[    0.468454]  [<ffffffff814d0944>] driver_probe_device+0x1f4/0x450
[    0.468458]  [<ffffffff814d0c30>] __driver_attach+0x90/0xa0
[    0.468463]  [<ffffffff814d0ba0>] ? driver_probe_device+0x450/0x450
[    0.468467]  [<ffffffff814ce40c>] bus_for_each_dev+0x6c/0xc0
[    0.468472]  [<ffffffff814d014e>] driver_attach+0x1e/0x20
[    0.468476]  [<ffffffff814cfc9b>] bus_add_driver+0x1eb/0x280
[    0.468481]  [<ffffffff81d6515f>] ? uncore_cpu_setup+0x12/0x12
[    0.468485]  [<ffffffff814d14a0>] driver_register+0x60/0xe0
[    0.468489]  [<ffffffff813e5b8c>] __pci_register_driver+0x4c/0x50
[    0.468494]  [<ffffffff81d65231>] intel_uncore_init+0xd2/0x2be
[    0.468498]  [<ffffffff81d6515f>] ? uncore_cpu_setup+0x12/0x12
[    0.468502]  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
[    0.468507]  [<ffffffff810bbee1>] ? parse_args+0x271/0x4a0
[    0.468512]  [<ffffffff81778e00>] ? ldsem_down_write+0x190/0x199
[    0.468516]  [<ffffffff81d571dc>] kernel_init_freeable+0x18e/0x228
[    0.468521]  [<ffffffff81769130>] ? rest_init+0x80/0x80
[    0.468525]  [<ffffffff8176913e>] kernel_init+0xe/0xe0
[    0.468529]  [<ffffffff817797df>] ret_from_fork+0x3f/0x70
[    0.468533]  [<ffffffff81769130>] ? rest_init+0x80/0x80
[    0.468539] ---[ end trace 4e962173ff9459d8 ]---
Comment 3 Bojan Smojver 2015-11-12 20:06:07 EST
So, obviously that first warning carrying a message of "Your kernel is fine" is not quite true.
Comment 4 Simon K 2015-11-13 04:49:16 EST
I'm getting what seems to be the same issue:

[    0.459292] ------------[ cut here ]------------
[    0.459298] WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
[    0.459303] Info: mapping multiple BARs. Your kernel is fine.
[    0.459305] Modules linked in:

[    0.459312] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.2.5-300.fc23.x86_64 #1
[    0.459317] Hardware name: LENOVO 20CKCTO1WW/20CKCTO1WW, BIOS N11ET30W (1.06 ) 02/03/2015
[    0.459322]  0000000000000000 00000000d0b2d265 ffff88043b773a78 ffffffff8177280a
[    0.459329]  0000000000000000 ffff88043b773ad0 ffff88043b773ab8 ffffffff8109e4b6
[    0.459335]  ffff88043b773ae8 00000000fed10000 ffffc90001918000 0000000000006000
[    0.459341] Call Trace:
[    0.459347]  [<ffffffff8177280a>] dump_stack+0x45/0x57
[    0.459352]  [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
[    0.459357]  [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
[    0.459362]  [<ffffffff81065b95>] __ioremap_caller+0x2c5/0x380
[    0.459366]  [<ffffffff81065c67>] ioremap_nocache+0x17/0x20
[    0.459372]  [<ffffffff81039c89>] snb_uncore_imc_init_box+0x79/0xb0
[    0.459376]  [<ffffffff81038434>] uncore_pci_probe+0xd4/0x1a0
[    0.459382]  [<ffffffff813e61a5>] local_pci_probe+0x45/0xa0
[    0.459387]  [<ffffffff8129a67d>] ? sysfs_do_create_link_sd.isra.2+0x6d/0xb0
[    0.459392]  [<ffffffff813e739d>] pci_device_probe+0xed/0x140
[    0.459398]  [<ffffffff814d07f4>] driver_probe_device+0x1f4/0x450
[    0.459403]  [<ffffffff814d0ae0>] __driver_attach+0x90/0xa0
[    0.459407]  [<ffffffff814d0a50>] ? driver_probe_device+0x450/0x450
[    0.459412]  [<ffffffff814ce2bc>] bus_for_each_dev+0x6c/0xc0
[    0.459416]  [<ffffffff814cfffe>] driver_attach+0x1e/0x20
[    0.459421]  [<ffffffff814cfb4b>] bus_add_driver+0x1eb/0x280
[    0.459425]  [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
[    0.459430]  [<ffffffff814d1350>] driver_register+0x60/0xe0
[    0.459435]  [<ffffffff813e5a8c>] __pci_register_driver+0x4c/0x50
[    0.459439]  [<ffffffff81d6521b>] intel_uncore_init+0xd2/0x2be
[    0.459443]  [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
[    0.459448]  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
[    0.459453]  [<ffffffff810bbee1>] ? parse_args+0x271/0x4a0
[    0.459459]  [<ffffffff81778c00>] ? ldsem_down_write+0x170/0x199
[    0.459464]  [<ffffffff81d571dc>] kernel_init_freeable+0x18e/0x228
[    0.459468]  [<ffffffff81768f50>] ? rest_init+0x80/0x80
[    0.459472]  [<ffffffff81768f5e>] kernel_init+0xe/0xe0
[    0.459476]  [<ffffffff817795df>] ret_from_fork+0x3f/0x70
[    0.459480]  [<ffffffff81768f50>] ? rest_init+0x80/0x80
[    0.459486] ---[ end trace 4749c98751814a90 ]---

Because this stack is referencing the "swapper" thread, I should perhaps mention that I have _no_ swap-space configured.

The system is pretty stable. However as with the original reporter, I did eventually get a "report kernel problem" prompt, which then refused to report as "the kernel is tainted". File /proc/sys/kernel/tainted reports "512", ie "warning occurred", presumably the one above.
Comment 5 Josh Boyer 2015-11-13 08:15:13 EST
(In reply to Bojan Smojver from comment #3)
> So, obviously that first warning carrying a message of "Your kernel is fine"
> is not quite true.

Both of these issues are tracked elsewhere.  The message is correct, but it has the side-effect of setting the W bit, which is a taint.
Comment 6 Bojan Smojver 2015-11-13 08:27:18 EST
Can you point to a duplicate or a bug upstream?
Comment 7 Josh Boyer 2015-11-13 08:35:21 EST
1181269 1279004
Comment 8 Bojan Smojver 2015-11-13 09:02:42 EST
(In reply to Josh Boyer from comment #7)
> 1181269 1279004

Both of these are the ioremap bugs. I meant the Intel driver bug (i.e. the second trace, the one that could not be reported because of a taint).

Note You need to log in before you can comment on or make changes to this bug.