Bug 128163 - PATCH: keypad +-*/ don't work when TERM=gnome or xterm-new
Summary: PATCH: keypad +-*/ don't work when TERM=gnome or xterm-new
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-19 15:08 UTC by Hans de Goede
Modified: 2013-07-02 23:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-23 07:32:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing the described problem (343 bytes, patch)
2004-07-19 15:08 UTC, Hans de Goede
no flags Details | Diff
patch fixing the described problem (419 bytes, patch)
2004-07-21 21:34 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2004-07-19 15:08:07 UTC
As a result of the fix for bug 122815, TERM will be set to gnome for
gnome-terminal and to xterm-new for the real xterm.

Because of this mc doesn't recognize the +-*/ keys on the keypad anymore.

This can be fixed by adding bindings for these to mc.lib, as the
attached patch does, I'll also submit this patch upstream.

Comment 1 Hans de Goede 2004-07-19 15:08:51 UTC
Created attachment 102040 [details]
patch fixing the described problem

Comment 2 Hans de Goede 2004-07-21 21:34:03 UTC
Created attachment 102119 [details]
patch fixing the described problem

I just noticed the same happens in rxvt, so here's a new patch also fixing
things for rxvt.

I've also reported this upstream, see:
https://savannah.gnu.org/bugs/?func=detailitem&item_id=9691

Comment 3 Jindrich Novy 2005-04-23 05:03:41 UTC
Hello Hans,

sorry that this bug was ignored for such a long time. It seems that this problem
is now solved by the recent mc? Could you please confirm that?

Thanks for the patch,
Jindrich

Comment 4 Hans de Goede 2005-04-23 07:31:30 UTC
I can confirm this is fixed in current rawhide, and I think it was fixed earlier
too.




Note You need to log in before you can comment on or make changes to this bug.