Bug 1281662 - rsyslog imjournal module fails in the presence of mmjsonparse
rsyslog imjournal module fails in the presence of mmjsonparse
Status: CLOSED DUPLICATE of bug 1238215
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 22:37 EST by Peter Portante
Modified: 2016-09-20 00:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 10:22:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Portante 2015-11-12 22:37:45 EST
It looks like the rsyslog-8.8.0-immutable-json-props.patch does not work when imjournal and mmjsonparse modules are present and in use together.

For example: if I have this in my rsyslog.conf file:

  module(load="imjournal" StateFile="/var/lib/rsyslog/imjournal.state")
  module(load="mmjsonparse")
  action(type="mmjsonparse")

Then the rsyslogd starts to chew up 100% CPU, logs are accepted, but nothing is emitted, and the memory usage of the process continues to grow.

See rsyslog upstream github issue, https://github.com/rsyslog/rsyslog/issues/593

The patch comment seems to indicate this is upstream, but it does not appear to be.  Seems like we should drop this patch given the problem it poses.
Comment 1 Peter Portante 2015-11-13 10:22:15 EST

*** This bug has been marked as a duplicate of bug 1238215 ***

Note You need to log in before you can comment on or make changes to this bug.