Bug 1281672 - [RFE] Add Support for RHEV block datastores smart state analysis
[RFE] Add Support for RHEV block datastores smart state analysis
Status: CLOSED DUPLICATE of bug 1208639
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
x86_64 Linux
high Severity high
: GA
: 5.6.0
Assigned To: Rich Oliveri
Ilanit Stein
smartstate:rhev
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 00:39 EST by Prasad Mukhedkar
Modified: 2016-06-30 02:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 02:04:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad Mukhedkar 2015-11-13 00:39:57 EST
For RHEV Prvider, Datastore scanning is currently limited to NFS backed storage domains only. Datastore Fleecing is not supported for ISCSI/FC backed storage domains. When performed, It fails with below error :

Datastore 'rhevm': Error during 'scan': Action not supported for Datastore Type [FCP]

For vmware provider, Fleecing works on all type of datastores.  

RHEV being a Red Hat product, it's kind of hard for us Red Hat Support and Partner to explain why a feature is missing on it.
Comment 2 Yaniv Kaul 2016-06-07 18:46:48 EDT
Ilanit - same as a previous bug 1273346 - check SSA on FC based storage - with Windows VM would be great.
Comment 3 Ilanit Stein 2016-06-29 03:38:38 EDT
Checked on versions:
CFME-5.6.0.11-rc2.2.20160614152915_f315c68
RHEVM-3.6.6.2-0.1

SmartState analysis is not available ("Perform SmartState Analysis" action is grayed out) for NFS/ISCSI/FC datastores, when entering the Datastore item.

Hovering over the grayed out, Perform SmartState analysis, it gives the reason:
"SmartState Analysis cannot be performed on selected DataStore"

If choosing this same DataStore, within the Datastore list, and perform SSA,
It give error in UI:
"Smartstate Analysis does not apply to at least one of the selected Datastores"
Comment 4 Ilanit Stein 2016-06-30 02:04:50 EDT

*** This bug has been marked as a duplicate of bug 1208639 ***

Note You need to log in before you can comment on or make changes to this bug.