Bug 128171 - cannot use wildcards in jk2 uri directive
cannot use wildcards in jk2 uri directive
Status: CLOSED NOTABUG
Product: Red Hat Application Server Public Beta
Classification: Retired
Component: tomcat (Show other bugs)
1.0-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 12:08 EDT by Peter Stiles
Modified: 2007-04-18 13:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 14:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Stiles 2004-07-19 12:08:43 EDT
Description of problem:

Using the standalone version of tomcat

Wildcards in "workers2.properties" in the "uri" section do not work.

Please note that this problem was reported to apache and resolved in
the bug

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21561

Version-Release number of selected component (if applicable):

mod_jk2-2.0.4-4jpp_3rh

How reproducible:

Try to use the following in workers2.properties:
[uri=/examples/*]

You should be able to use "http://localhost/examples/" but this
generates an apache 404 message.
The only way to make the application work is to use multiple entries
in the worker2.properties, making deployment of a web application much
more complex than is necessary and making use of the standard "admin"
and "manager" tomcat applications rather difficult.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The issue is noted on the apache bugzilla report above. It does not
appear to have been fixed in the latest mod_jk2 available via up2date
(as of today 19th July 2004)
Comment 1 Fernando Nasser 2004-07-19 14:10:28 EDT
Duplicate of #126476

See how to specify wildcards there.
Comment 2 Peter Stiles 2004-07-20 06:48:10 EDT
Following the instructions in #126476 works, thank you very much.

As this "$" syntax is *not* mentioned in the JK documentation 
anywhere I can find, does anyone know whether this is still a "bug" 
in the JK module or whether it is an error in the documentation?
Comment 3 Fernando Nasser 2004-07-21 04:52:13 EDT
I believe it is a documentation bug.

Could you please open a bug report against mod_jk2 so someone gets it
fixed?

Best regards.

Note You need to log in before you can comment on or make changes to this bug.