Bug 1281833 - PPD for HP Photosmart c4600 series missing in F23 hplip
PPD for HP Photosmart c4600 series missing in F23 hplip
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 09:39 EST by Alessandro Suardi
Modified: 2015-11-14 08:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 06:16:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Suardi 2015-11-13 09:39:27 EST
Description of problem:
HP Photosmart c4680 driver PPD file not present when installing via CUPS Web GUI; that used to be packaged in hplip in F21 and earlier. F22 GNOME also discovered the printer correctly.

Version-Release number of selected component (if applicable):
hplip-3.15.9-2.fc23.x86_64

How reproducible:
Apparently 100%.

Steps to Reproduce:
1. install F23 XFCE (actually dnf system-upgrade from F22 XFCE, where printer was not yet discovered - but it was in a previous incarnation of F22 GNOME on the same Acer Aspire Revo 3600 nettop)
2. try to add new printer via CUPS Web GUI
3. read list of possible supported printers

Actual results:
Photosmart C4600 series drivers can not be found


Expected results:
Photosmart C4600 series drivers should be found

Additional info:
As a workaround, downloading hplip 3.15.9 from sourceforge, extracting the relevand PPD (hp-photosmart_c4600_series.ppd.gz) and passing it to the interactive "specify driver" dialog works.
Comment 1 Jiri Popelka 2015-11-13 12:50:11 EST
hmm, I can (hplip-3.15.9-2.fc23.x86_64) see it there (cups web UI) as well as in system-config-printer and
# lpinfo -l -m | grep -i C4600
Model:  name = drv:///hp/hpcups.drv/hp-photosmart_c4600_series.ppd
        make-and-model = HP Photosmart c4600 Series, hpcups 3.15.9
        device-id = MFG:HP;MDL:photosmart c4600 series;DES:photosmart c4600 series;
Comment 2 Alessandro Suardi 2015-11-13 14:37:04 EST
Well, I now have

[root@torrent ~]# lpinfo -l -m | grep -i C4600
Model:  name = drv:///hp/hpijs.drv/hp-photosmart_c4600_series-hpijs.ppd
        make-and-model = HP Photosmart c4600 Series hpijs, 3.15.9
        device-id = MFG:HP;MDL:photosmart c4600 series;DES:photosmart c4600 series;
Model:  name = drv:///hp/hpcups.drv/hp-photosmart_c4600_series.ppd
        make-and-model = HP Photosmart c4600 Series, hpcups 3.15.9
        device-id = MFG:HP;MDL:photosmart c4600 series;DES:photosmart c4600 series;


 - but what is the relevant PPD file and in which package should it be?

Because it's not where others are:

[root@torrent HP]# pwd
/usr/share/ppd/HP
[root@torrent HP]# ls | wc -l
258
[root@torrent HP]# ls | grep -i 4600
hp-color_laserjet_4600-ps.ppd.gz
hp-color_laserjet_4600_series-ps.ppd.gz
[root@torrent HP]# 

Obviously, color_laserjet is not the same family as photosmart...

And:

[root@torrent HP]# rpm -ql hplip|grep -i photo
/usr/share/hplip/pcard/photocard.py
/usr/share/ppd/HP/hp-designjet_z6100ps_42in_photo-ps.ppd.gz
/usr/share/ppd/HP/hp-designjet_z6100ps_60in_photo-ps.ppd.gz
/usr/share/ppd/HP/hp-designjet_z6200_42in_photo-ps.ppd.gz
/usr/share/ppd/HP/hp-designjet_z6200_60in_photo-ps.ppd.gz
/usr/share/ppd/HP/hp-designjet_z6800_photo-postscript.ppd.gz
[root@torrent HP]#
Comment 3 Jiri Popelka 2015-11-14 06:16:05 EST
The PPD file is generated automatically by CUPS from driver info file:
/usr/share/cups/drv/hp/hpcups.drv

https://www.cups.org/documentation.php/doc-2.1/ppd-compiler.html#DRV
Comment 4 Alessandro Suardi 2015-11-14 08:08:45 EST
Thanks for the clarification, and indeed this is NOTABUG - rather a pilot error.

I went back again in the CUPS Web GUI, pretending to modify the printer in order to change its driver, and I spotted the actual problem - I must have originally been looking in the list of Photosmart NNNN models (where there is no 4NNN model) instead of the Photosmart cNNNN models (where the c4600 family is correctly present).

Note You need to log in before you can comment on or make changes to this bug.