Bug 1281884 - Error raising request scan event for ManageIQ::Providers::Openstack::InfraManager::Host name:
Error raising request scan event for ManageIQ::Providers::Openstack::InfraMan...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 12:21 EST by Marius Cornea
Modified: 2015-11-13 15:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 15:55:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-13 12:21:07 EST
Description of problem:
When doing SSA on multiple Openstack Infra provider nodes the SSA fails for some them and they through the following error:

[----] W, [2015-11-13T12:16:29.738058 #14648:f0198c]  WARN -- : MIQ(ManageIQ::Providers::Openstack::InfraManager::Host#scan) Error raising request scan event for ManageIQ::Providers::Openstack::InfraManager::Host name: [0647e08d-1b42-4f0a-8061-f599dcfc7e21 (NovaCompute)], id: [4]: A group is needed to raise an event. [ManageIQ::Providers::Openstack::InfraManager::Host] id:[4] event_type: [request_host_scan]


Version-Release number of selected component (if applicable):
5.5.0.10-beta2.1.20151110134042_d6f5459

How reproducible:
100%

Steps to Reproduce:
1. Add Opensack Platorm Director with multiple nodes (15 available nodes - 7 provisioned nodes in my environment) 
2. Select all 
3. Configuration - Perform SmartState Analysis


Actual results:
SSA does not run for 3 of the nodes. 

Expected results:
SSA completes ok for all of the nodes.

Additional info:
[----] W, [2015-11-13T12:16:29.738058 #14648:f0198c]  WARN -- : MIQ(ManageIQ::Providers::Openstack::InfraManager::Host#scan) Error raising request scan event for ManageIQ::Providers::Openstack::InfraManager::Host name: [0647e08d-1b42-4f0a-8061-f599dcfc7e21 (NovaCompute)], id: [4]: A group is needed to raise an event. [ManageIQ::Providers::Openstack::InfraManager::Host] id:[4] event_type: [request_host_scan]
Comment 2 John Hardy 2015-11-13 14:42:41 EST
When it fails is it only when issuing multiple SSA's in parallel? thanks
Comment 3 Marius Cornea 2015-11-13 15:55:25 EST
I did an additional set of tests and the nodes where SSA failed were associated to a deleted Openstack Director provider. I couldn't reproduce the issue on a fresh environment. I'll close this one as not a bug.

Note You need to log in before you can comment on or make changes to this bug.