Bug 1281905 - VMs can't be booted with networks without subnet
VMs can't be booted with networks without subnet
Status: CLOSED NEXTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Sahid Ferdjaoui
nlevinki
https://blueprints.launchpad.net/nova...
upstream_milestone_none upstream_defi...
: FutureFeature, Triaged
Depends On:
Blocks: 1281573
  Show dependency treegraph
 
Reported: 2015-11-13 13:52 EST by Stephen Gordon
Modified: 2016-05-10 13:36 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 13:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1304409 None None None Never
OpenStack gerrit 284095 None None None 2016-04-11 14:34 EDT

  None (edit)
Description Stephen Gordon 2015-11-13 13:52:17 EST
Cloned from launchpad bug 1304409.

Description:

Recently a change in the nova/network/neutronv2/api.py file is causing nova boots to fail for networks that do not have a subnet associated with them.

The following line in the api.py file is causing the issue:

            for net in nets:
                if not net.get('subnets'):
                    raise exception.NetworkRequiresSubnet(
                        network_uuid=net['id'])

This has to be fixed to allow users to do boots with networks that do not have a subnet associated with them.

The issue seems to be occuring post the commit done here: 

https://review.openstack.org/gitweb?p=openstack%2Fnova.git;a=commitdiff;h=45e2398f0c01c327db46ce92fb9dda886455db9d

Specification URL (additional information):

https://bugs.launchpad.net/nova/+bug/1304409

Note You need to log in before you can comment on or make changes to this bug.