Bug 128203 - Wrong permissions on /etc/sudoers will cause sudo to hang
Wrong permissions on /etc/sudoers will cause sudo to hang
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-19 22:10 EDT by Daryll
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2004-07-19 22:10:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:

If the permissions are set wrong on /etc/sudoers to something other
than 0440 will cause sudo to hang for a long time any time it is
invoked. Since it ignores ctrl-c and ctrl-z it ties up the console.

I understand forcing a delay when sudo is use inappropriately but:
   1) This is a configuration error not a user trying to break it.
   2) This is a really long delay. I thought it had hung completely.

Version-Release number of selected component (if applicable):
sudo-1.6.7p5-26

How reproducible:
Always

Steps to Reproduce:
1. Become root
2. chmod u+w /etc/sudoers
3. sudo
    

Actual Results:  
It prints that the permissions are wrong then just hangs and ignores
ctrl-c and ctrl-z

Expected Results:  It should print a message and quite after a short
period of time.

Additional info:
Comment 1 Thomas Woerner 2004-08-25 11:20:07 EDT
Do you have made changes to /etc/sudoers?
Comment 2 Daryll 2004-08-25 11:28:42 EDT
Yes, I've got exactly one entry in my sudo file:

daryll ALL=(ALL) ALL

Sudo prints the message saying the permission is wrong right away, but
waits a minute before exiting.
Comment 3 Thomas Woerner 2004-10-08 09:33:24 EDT
I can not reproduce this problem at all. sudo is coming back without
any delay.
Comment 4 Daryll 2004-10-08 11:23:53 EDT
I recently installed FC3T2 and it still happens for me. 

Obviously there's something else involved here. The length of time
sounds like a network timeout.

If you can't reproduce it, I guess it's something peculiar to my machine.
Comment 5 Thomas Woerner 2004-10-19 05:36:57 EDT
Are you using nis or ldap?
Comment 6 Karel Zak 2005-09-08 06:55:47 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Note You need to log in before you can comment on or make changes to this bug.