Bug 1282046 - sddm 0.12.0 breaks multimonitor layout
sddm 0.12.0 breaks multimonitor layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 10:34 EST by Corinna Vinschen
Modified: 2015-11-30 05:39 EST (History)
6 users (show)

See Also:
Fixed In Version: sddm-0.13.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 05:39:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my theme directory and Xsetup file (1.03 MB, application/x-xz)
2015-11-14 10:34 EST, Corinna Vinschen
no flags Details

  None (edit)
Description Corinna Vinschen 2015-11-14 10:34:28 EST
Created attachment 1094061 [details]
my theme directory and Xsetup file

Description of problem:

  On system with two screens, layout like this:

          +----------+
    +-----+          |
    |     |          |    screen 1, HDMI1, 1600x1200
    |  1  |     2    |
    |     |          |    screen 2,   DP1, 2560x1440
    +-----+          |
          +----------+

  Using my own sddm theme (attached) based on "Circles" with
  different background pictures on screeen 1 and 2.

  Worked fine with sddm 0.10.0-4

  Now broken with sddm-0.12.0-5:  On screen 2 only the left 1/3rd (give or
  take) of the background picture is shown.  The right 2/3rd of the screen
  is black and shows the boot messages generated in non-rhgb mode.
  This is stable even when logging out again.

  Downgrading to sddm-0.10.0-4 restores the full background picture on
  screen 2.

Version-Release number of selected component (if applicable):

  0.12.0-5

How reproducible:

  Use my attached theme

Steps to Reproduce:
1. Install my attached theme on a machine with 2 screens attached.
2. Set it up as sddm theme, use an Xsetup along the lines of the one
   in the attached theme file.
3. Reboot.

Actual results:

  The right 2/3rd of the 2nd screen only show the boot screen content.

Expected results:

  Full configured picture on screen 2, as with sddm-0.10.0-4.


Thanks,
Corinna
Comment 1 Pier Luigi Fiorini 2015-11-14 10:44:29 EST
This should be fixed upstream with sddm 0.13.0
Comment 2 Rex Dieter 2015-11-15 08:02:47 EST
ok, working on 0.13.0 now
Comment 3 Fedora Update System 2015-11-15 08:05:06 EST
sddm-0.13.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0c4711f24d
Comment 4 Corinna Vinschen 2015-11-15 11:27:39 EST
Thanks for the update but it only works marginally better.

Screen 2 is now fully graphical (no more boot screen residue), but it's invariably just a copy of screen 1, with dialog- and mouse-sharing.
Reusing the ASCII-art from my OP, this is the result:

          +----------+
    +-----+          |
    |     |          |
    |  1  |     1    |
    |     |          |
    +-----+          |
          +----------+


Corinna
Comment 5 Fedora Update System 2015-11-15 23:51:08 EST
sddm-0.13.0-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update sddm'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0c4711f24d
Comment 6 Corinna Vinschen 2015-11-16 13:23:03 EST
Hi Rex,

rdieter asked on bodhi:
> Are you sure your configured Xsetup file is referenced in your sddm.conf ?
> Note: recent sddm builds changed the default location of configurable files
> to /etc/sddm (rather than /usr/share/sddm/scripts, where modifications get 
> lost on package updates)

Yes, I'm sure.  My sddm.conf contains the line

  DisplayCommand=/usr/share/sddm/scripts/Xsetup.CV

already for some time since I didn't want my Xsetup to be overridden when
installing a new sddm package :)

That Xsetup.CV file has the content as the Xsetup file from my attachment
to this BZ.

For testing I commented out the DisplayCommand line and copied my
/usr/share/sddm/scripts/Xsetup.CV to /etc/sddm/Xsetup, then restarted the
sddm service, but to no avail.  The effect is as described in my previous
reply.  Additionally I also copied /usr/share/sddm/scripts/Xsetup.CV
to /usr/share/sddm/scripts/Xsetup, just to be sure if sddm doesn't
accidentally pich up that file, but with no changes in the result either.

Btw., the new default /etc/sddm.conf still contains this line:

  #DisplayCommand=/usr/share/sddm/scripts/Xsetup

Since the default changed to /etc/sddm/Xsetup, shouldn't the sddm.conf
comment refer to the new default as well?


Thanks,
Corinna
Comment 7 Rex Dieter 2015-11-16 13:24:38 EST
Yes, I noticed that too about sddm.conf after making the prior comment, and am fixing that now.
Comment 8 Fedora Update System 2015-11-16 13:55:45 EST
sddm-0.13.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0c4711f24d
Comment 9 Fedora Update System 2015-11-18 19:23:04 EST
sddm-0.13.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update sddm'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0c4711f24d
Comment 10 Fedora Update System 2015-11-29 01:23:29 EST
sddm-0.13.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Corinna Vinschen 2015-11-29 08:01:20 EST
Closing this bug report is really not prudent.   It's not fixed at all.


Thanks,
Corinna
Comment 12 Rex Dieter 2015-11-29 08:03:29 EST
Sorry, initially submitted it per comment #1

I'd suggest you contact upstream,
https://github.com/sddm/sddm/issues
Comment 13 Corinna Vinschen 2015-11-30 04:46:47 EST
Done: https://github.com/sddm/sddm/issues/565
Comment 14 Corinna Vinschen 2015-11-30 05:39:56 EST
As discussed in https://github.com/sddm/sddm/issues/565,
the multi-monitor setup requires a change in the theme.
That's a bit unfortunate (and non-obvious), but now my
theme works with 0.13.  Case closed.


Corinna

Note You need to log in before you can comment on or make changes to this bug.