This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282121 - GSL 2.1 support
GSL 2.1 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: octave-gsl (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 19:13 EST by Orion Poplawski
Modified: 2016-07-19 13:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 13:25:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2015-11-14 19:13:40 EST
Description of problem:

It appears that octave-gsl is unmaintained upstream.  I'm looking at updating gsl to 2.1, but it breaks octave-gsl due to API changes.  Unless you want to fix this yourself or find a new upstream, I think it's time to retire this package.

https://copr.fedoraproject.org/coprs/orion/gsl2/package/octave-gsl/
Comment 1 Susi Lehtola 2015-11-15 17:01:05 EST
Should be fixed in rawhide branch, please try it out.
Comment 2 Orion Poplawski 2015-11-16 12:00:51 EST
Not quite:

g++ -c  -fPIC -I/usr/include/octave-4.0.0/octave/.. -I/usr/include/octave-4.0.0/octave -pthread -fopenmp -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic    -DHAVE_OCTAVE_40 legendre_sphPlm_array.cc -o legendre_sphPlm_array.o
legendre_sphPlm_array.cc: In function 'octave_value_list Flegendre_sphPlm_array(const octave_value_list&, int)':
legendre_sphPlm_array.cc:81:66: error: cannot convert 'double' to 'double*' for argument '4' to 'int gsl_sf_legendre_array(gsl_sf_legendre_t, size_t, double, double*)'
     gsl_sf_legendre_array (GSL_SF_LEGENDRE_SPHARM, lmax, m, x, yd);
                                                                  ^
Makefile:20: recipe for target 'legendre_sphPlm_array.oct' failed
Comment 3 Susi Lehtola 2015-11-17 12:33:39 EST
Well, now it should work.
Comment 4 Orion Poplawski 2015-11-17 18:25:38 EST
Confirmed.  Thanks!
Comment 5 Jan Kurik 2016-02-24 10:31:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.