Bug 128213 - net join rpc segfaults
net join rpc segfaults
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Depends On:
  Show dependency treegraph
Reported: 2004-07-20 04:51 EDT by Joachim Sauer
Modified: 2014-08-31 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-30 09:09:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Sauer 2004-07-20 04:51:01 EDT
Trying to join a domain to allow winbind to authenticat the users
trough our PDC fails with a segfault. The command I tried is
documented at

# net rpc join -S <PDC> -U <Administrator>

This will first query for the admin-password, then print a success
message and then crash with a segfault.

I've gone through exactly the same steps on a computer running Debian
testing on x86 (unfortunately i wasn't able to try it either on
Debian/amd64 nor on FC2/x86 yet) and they worked as intended.

I'll try to attach the exact output of the command as soon as the
admin is back (I don't have the admin-password of our Windows domain
so I can't test it right now ...)

(I've also tried it with the version supplied in FC2 before trying the
version from test: same result)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. net rpc join -S <PDC> -U Administrator
2. enter Administrator password

Actual Results:  
- see message about successfully joining the domain
- segfault, nothing in the configuration is changed

Expected Results:  
- see message about successfully joining the domain
- machine is joined to ADS domain and winbind can list users (after
additional configuration).
Comment 1 Tim Fletcher 2004-09-06 10:45:13 EDT
I think I have very similar problem with current samba (3.0.6-2.fc2)
and joining an ADS as the "net ads join" command seg faults on join.
However "net rpc join" works
Comment 2 Tim Fletcher 2004-09-06 10:59:29 EDT
I have now installed the i386 rpm of samba client and I can join and
use the ADS domain without problems.
Comment 3 Thomas M Steenholdt 2004-11-15 04:14:49 EST
This is still a problem on x86_64 in FC3 (even current development
version - 3.0.8-3)

Please move bug up to FC3, so that we can have this fixed?
Comment 4 Matthew Miller 2005-04-26 12:21:53 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 John Thacker 2006-10-30 09:09:38 EST
Closing per lack of response to previous request for information.
Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.
Comment 6 Tim Fletcher 2006-10-30 18:11:28 EST
This bug is fixed in current versions of fedora core

Note You need to log in before you can comment on or make changes to this bug.