Bug 1282134 - [SKIA] disabled skia causes scaled-down images to look awful
[SKIA] disabled skia causes scaled-down images to look awful
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-14 21:03 EST by Andrew Schultz
Modified: 2016-01-04 09:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 08:17:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot from URL mentioned above, rendered with Fedora's Firefox v42 (8.72 KB, image/png)
2015-11-14 21:03 EST, Andrew Schultz
no flags Details
screenshot of same page, rendered with Mozilla's Firefox v42 (10.56 KB, image/png)
2015-11-14 21:06 EST, Andrew Schultz
no flags Details

  None (edit)
Description Andrew Schultz 2015-11-14 21:03:08 EST
Created attachment 1094294 [details]
Screenshot from URL mentioned above, rendered with Fedora's Firefox v42

Description of problem:
skia is explicitly disabled in Fedora's firefox package.  One noticeable effect is that scaled-down images look pixelated.  If there is text in the image, it can be unreadable.  I'm not sure why skia is disabled; the changelog mentions fixes to get skia working on arm platforms around v37, but nothing since then.  Skia is enabled in binary builds from Mozilla.  With skia enabled, scaled-down images get anti-aliased and look better.

Version-Release number of selected component (if applicable):
firefox-42.0-2.fc23

Steps to Reproduce:
1. Visit http://rheneas.eng.buffalo.edu/~andrew/ff-scaling.html in Fedora's Firefox.  
3. Note that text is hard to read 
4. Build without skia disabled or use a binary build from mozilla
5. Visit http://rheneas.eng.buffalo.edu/~andrew/ff-scaling.html
7. Note that text is small but readable.

While scaled-down text images are not the most common thing, they often result from page-spanning images viewed on a low resolution display (or in a small browser window) like https://spins.fedoraproject.org/kde/

Please re-enable skia.
Comment 1 Andrew Schultz 2015-11-14 21:06 EST
Created attachment 1094295 [details]
screenshot of same page, rendered with Mozilla's Firefox v42

With Mozilla's Firefox, the text is readable down to 6px (especially if the scaling is due to a low-res display, which would make the text bigger).  Fedora's Firefox looks similarly readable at 11px.
Comment 2 Martin Stransky 2016-01-04 07:45:02 EST
Yes, I can reproduce it. Although the Skia backend is still disabled in Firefox (https://bugzilla.mozilla.org/show_bug.cgi?id=1038800) looks like the Skia is used for a final layer composition and affect the scaling here.
Comment 3 Martin Stransky 2016-01-04 08:17:44 EST
Enabled in Rawhide.
Comment 4 Andrew Schultz 2016-01-04 09:08:45 EST
(In reply to Martin Stransky from comment #2)
> Yes, I can reproduce it. Although the Skia backend is still disabled in
> Firefox (https://bugzilla.mozilla.org/show_bug.cgi?id=1038800) looks like
> the Skia is used for a final layer composition and affect the scaling here.

Mozilla absolutely ships linux builds with skia enabled in the buildconfig (they do not --disable-skia) although they may not be enabling it for everything it can do (the prefs in https://bugzilla.mozilla.org/show_bug.cgi?id=740200#c44).  This bug is just requesting enabling the buildconfig option, which would match upstream.

Note You need to log in before you can comment on or make changes to this bug.