Bug 128214 - Clock applet text entry cropped when panel height set to 24 pixels
Clock applet text entry cropped when panel height set to 24 pixels
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 129767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 05:17 EDT by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 12:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of clock applet where text entry is cropped at the bottom. (5.60 KB, image/png)
2004-07-20 05:19 EDT, Joachim Frieben
no flags Details
Screenshot of clock applet where text entry is cropped at the bottom. (5.79 KB, image/png)
2004-08-09 14:47 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2004-07-20 05:17:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040625 Epiphany/1.2.6

Description of problem:
Setting the Gnome panel height to 24 pixels, the date entry of the
clock applet gets cropped at the bottom. The whole text line is not
centered vertically anymore but shifted to the bottom by about 1 pixel
which is seemingly the reason for this behaviour.

Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-10

How reproducible:
Always

Steps to Reproduce:
1. Set Gnome panel height to 24 pixels.
2. Choose date to be displayed by clock applet.


Actual Results:  Text appears cropped (see attached screenshot) and
off-center.

Expected Results:  Text should be centered vertically without being
cropped.

Additional info:

This may be related to a bug in some underlying library or even the X
server. I had installed Fedora Core 3 Test 1 on an different machine
by means of the QEMU emulator (host OS was Red Hat Linux 8) and in
this case, the clock applet text *was* centered vertically without
being cropped.
Comment 1 Joachim Frieben 2004-07-20 05:19:12 EDT
Created attachment 102066 [details]
Screenshot of clock applet where text entry is cropped at the bottom.
Comment 2 Joachim Frieben 2004-08-09 14:45:58 EDT
Huh, just upgraded various GNOME components from the Fedora
development tree, and things get even worse (see attached screenshot).
Comment 3 Joachim Frieben 2004-08-09 14:47:46 EDT
Created attachment 102534 [details]
Screenshot of clock applet where text entry is cropped at the bottom.

I forgot: applicable component is now gnome-panel-2.6.0-11.
Comment 4 Mark McLoughlin 2004-08-11 12:18:17 EDT
For reference, the upstream bug report is:

  http://bugzilla.gnome.org/show_bug.cgi?id=147999
Comment 5 Mark McLoughlin 2004-08-12 12:19:38 EDT
*** Bug 129767 has been marked as a duplicate of this bug. ***
Comment 6 Thorsten Leemhuis 2004-09-22 02:05:11 EDT
Just FYI, seeing this bug with FC2 since since FC2 updates
gtk2-2.4.7-2.5 and also with gtk2-2.4.7-2.6 (currently in testing).
Panel height 16 pixel, worked fine before update.
Comment 7 Mark McLoughlin 2004-09-27 12:20:31 EDT
Just fixed this upstream:

  http://bugzilla.gnome.org/show_bug.cgi?id=147999

Fix will be in before FC3 test3 devel freeze.

Note You need to log in before you can comment on or make changes to this bug.