Bug 1282160 - Remote JConsole Fails
Remote JConsole Fails
Status: CLOSED WORKSFORME
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting (Show other bugs)
6.4.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Enrique Gonzalez Martinez
Michal Vinkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 02:16 EST by BUNTY RAY
Modified: 2017-01-11 04:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-11 04:48:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JCONSOLE SCREEN ON WINDOWS (97.98 KB, image/png)
2015-11-15 02:16 EST, BUNTY RAY
no flags Details

  None (edit)
Description BUNTY RAY 2015-11-15 02:16:08 EST
Created attachment 1094324 [details]
JCONSOLE SCREEN ON WINDOWS

Description of problem:

Accessing remote EAP 6 from Jconsole.bat on Windows fails with Null Pointer exception.

Nov 15, 2015 1:55:30 AM org.xnio.Xnio <clinit>
INFO: XNIO Version 3.0.13.GA-redhat-1
Nov 15, 2015 1:55:30 AM org.xnio.nio.NioXnio <clinit>
INFO: XNIO NIO Implementation Version 3.0.13.GA-redhat-1
Nov 15, 2015 1:55:30 AM org.jboss.remoting3.EndpointImpl <clinit>
INFO: JBoss Remoting version 3.3.4.Final-redhat-1
Exception in thread "AWT-EventQueue-0" java.lang.ExceptionInInitializerError
	at org.jboss.as.cli.gui.JConsoleCLIPlugin.getTabs(JConsoleCLIPlugin.java:83)
	at sun.tools.jconsole.VMPanel.createPluginTabs(VMPanel.java:652)
	at sun.tools.jconsole.VMPanel.propertyChange(VMPanel.java:324)
	at java.beans.PropertyChangeSupport.fire(PropertyChangeSupport.java:335)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:327)
	at javax.swing.event.SwingPropertyChangeSupport.firePropertyChange(SwingPropertyChangeSupport.java:92)
	at javax.swing.event.SwingPropertyChangeSupport$1.run(SwingPropertyChangeSupport.java:97)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:745)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:715)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.NullPointerException
	at sun.misc.MetaIndex.mayContain(MetaIndex.java:243)
	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:830)
	at sun.misc.URLClassPath.getResource(URLClassPath.java:199)
	at sun.misc.URLClassPath.getResource(URLClassPath.java:251)
	at java.lang.ClassLoader.getBootstrapResource(ClassLoader.java:1305)
	at java.lang.ClassLoader.getResource(ClassLoader.java:1144)
	at java.lang.ClassLoader.getResource(ClassLoader.java:1142)
	at java.lang.Class.getResource(Class.java:2147)
	at org.jboss.as.cli.gui.GuiMain.<clinit>(GuiMain.java:63)
	... 21 more

Version-Release number of selected component (if applicable):
6.4.0

How reproducible: 
C:\EAP-6.4.0\bin>jconsole.bat -J-Djava.class.path="C:\Program Files\Java\jdk1.7.0_79\lib\tools.jar";"C:\Program Files\Java\jdk1.7.0_79\lib\jconsole.jar";"C:\EAP-6.4.0\bin\client
\jboss-client.jar"

Steps to Reproduce:
1. JBoss is installed in Linux
2. On Windows installed a local JBoss EAP 6
3. Access the remote EAP from Jconsole.bat on Windows

Actual results: Null Pointer Exception


Expected results:


Additional info:
Comment 2 Enrique Gonzalez Martinez 2017-01-11 04:48:35 EST
tested with 6.4.12GA windows 7 (jconsole) and linux (server) and working porperly.

Note You need to log in before you can comment on or make changes to this bug.