Bug 1282207 - [abrt] kf5-kinit: KCrash::defaultCrashHandler(): kdeinit5 killed by SIGABRT
[abrt] kf5-kinit: KCrash::defaultCrashHandler(): kdeinit5 killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kf5-kinit (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e38d59194b886c8d3e6a04ddd45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 09:12 EST by Fabio Correa
Modified: 2016-01-22 09:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 09:21:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.36 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: core_backtrace (9.70 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: dso_list (19.15 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: environ (4.70 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: maps (85.66 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: mountinfo (3.01 KB, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: namespaces (85 bytes, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: open_fds (189 bytes, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details
File: proc_pid_status (1016 bytes, text/plain)
2015-11-15 09:12 EST, Fabio Correa
no flags Details

  None (edit)
Description Fabio Correa 2015-11-15 09:12:21 EST
Description of problem:
kscreenlock_greeter has been left as a zombie process several times since I upgraded to Fedora 23. The X session has been unresponsive as a result. I sent SIGABRT to its parent and the X session restarted. This is the report on that signal.

Version-Release number of selected component:
kf5-kinit-5.15.0-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        'ksmserver [kdeinit5] --lockscreen' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
crash_function: KCrash::defaultCrashHandler
executable:     /usr/bin/kdeinit5
global_pid:     3170
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 KCrash::defaultCrashHandler at ../../src/kcrash.cpp:418
 #3 poll at ../sysdeps/unix/syscall-template.S:84
 #5 _xcb_conn_wait at xcb_conn.c:459
 #6 wait_for_reply at xcb_in.c:516
 #7 xcb_wait_for_reply at xcb_in.c:546
 #9 XGetGeometry at GetGeom.c:47
 #10 ScreenLocker::LockWindow::nativeEventFilter at ../../../ksmserver/screenlocker/lockwindow.cpp:328
 #11 QAbstractEventDispatcher::filterNativeEvent at kernel/qabstracteventdispatcher.cpp:460
 #12 QXcbConnection::handleXcbEvent at qxcbconnection.cpp:997
 #13 QXcbConnection::processXcbEvents at qxcbconnection.cpp:1487
Comment 1 Fabio Correa 2015-11-15 09:12:26 EST
Created attachment 1094431 [details]
File: backtrace
Comment 2 Fabio Correa 2015-11-15 09:12:27 EST
Created attachment 1094432 [details]
File: cgroup
Comment 3 Fabio Correa 2015-11-15 09:12:28 EST
Created attachment 1094433 [details]
File: core_backtrace
Comment 4 Fabio Correa 2015-11-15 09:12:30 EST
Created attachment 1094434 [details]
File: dso_list
Comment 5 Fabio Correa 2015-11-15 09:12:31 EST
Created attachment 1094435 [details]
File: environ
Comment 6 Fabio Correa 2015-11-15 09:12:32 EST
Created attachment 1094436 [details]
File: limits
Comment 7 Fabio Correa 2015-11-15 09:12:34 EST
Created attachment 1094437 [details]
File: maps
Comment 8 Fabio Correa 2015-11-15 09:12:35 EST
Created attachment 1094438 [details]
File: mountinfo
Comment 9 Fabio Correa 2015-11-15 09:12:36 EST
Created attachment 1094439 [details]
File: namespaces
Comment 10 Fabio Correa 2015-11-15 09:12:37 EST
Created attachment 1094440 [details]
File: open_fds
Comment 11 Fabio Correa 2015-11-15 09:12:38 EST
Created attachment 1094441 [details]
File: proc_pid_status
Comment 12 Fabio Correa 2016-01-22 09:21:51 EST
I am certain that a bugfix for Fedora 23 has fixed this bug as well. I will not to identify that solution, but thanks for the hard work.

Note You need to log in before you can comment on or make changes to this bug.