Bug 128223 - Can't load i2o_scsi module for Adaptec AIC-7899 SCSI controller
Can't load i2o_scsi module for Adaptec AIC-7899 SCSI controller
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 09:04 EDT by StefanSchlesinger
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 02:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my dmesg output (2.72 KB, text/plain)
2004-07-20 09:12 EDT, StefanSchlesinger
no flags Details

  None (edit)
Description StefanSchlesinger 2004-07-20 09:04:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.1)
Gecko/20040707

Description of problem:
>> Hardware:
   Tyan S2688W w/ Adaptec AIC-7899W SCSI controller, SCSI Bios: 3.10S1
   -------------------------------------------------------------------
>> uname -a:
   Linux <host> 2.6.5-1.358 #1 May 8 09:00:01 EDT 2004 i686 unknown
   -------------------------------------------------------------------

>> Description
I'm trying to get FC2 working on my machine, but as i figured out
shortly its a way harder than i've thought. So here is what i did: I
started off the FC2 boot disk and followed the instructions at: 
http://www.redhat.com/archives/fedora-list/2004-May/msg03906.html to
get my Adaptec AIC-7899 scsi controller working.

But that didn't work at all, i can load i2o_core.ko, i2o_config.ko,
i2o_proc.ko, i2o_block.ko  ... in this order ... but when it comes to
i2o_scsi.ko i can't load this one. The module is at version 0.1.2

Here is what i get at TTY4:
<6> i2o_scsi.c: Version 0.1.2
<3> i2o_scsi: Unable to install OSM handler.

The SCSI controller last worked with RH9 under a 2.4 kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1. Get an Tyan S2688W or any other mainboard with AIC-7899W
2. Extract the i2o modules onto a floppy disk
3. Boot off FC2 cd
4. Insert the disk and as soon as possible change to TTY2 
5. load the modules in order as descriped above
6. view TTY3/TTY4

Actual Results:  Can't load the scsi modules.

<6> i2o_scsi.c: Version 0.1.2
<3> i2o_scsi: Unable to install OSM handler.

Expected Results:  Load the scsi modules and access my scsi disks

Additional info:
Comment 1 StefanSchlesinger 2004-07-20 09:12:28 EDT
Created attachment 102069 [details]
my dmesg output

htis is the output of dmesg
Comment 2 David Allen 2005-04-11 15:37:00 EDT
This may be related to my problems installing both FC3 and FC4t1 on a Tyan S2462
mobo with on-board Adaptec 7899 SCSI controller. The install also failed with FC2.

I also tried loading the I2O module to no avail. In fact, the module would not
load at all with the installer's insmod/modprobe.

However, I found that only the normal aic7xxx driver is needed after all, at
least in the case of both FC3 and FC4t1. I haven't tried FC2 yet.

You must wait for at least 25 minutes for the installer to finish
probing/initializing the AIC7899. After that, the install will proceed
normally. See bug 152660 (FC4t1).
Comment 3 Warren Togami 2005-04-11 17:22:40 EDT
i2o_scsi is not meant to be used by anything except to directly access SCSI
disks on an I2O RAID controller for DIAGNOSTIC PURPOSES only.

Is your controller an I2O RAID controller?  If so then logical block devices for
defined RAID arrays and partitions are available in /dev/i2o/hd*.  If your
controller is not an I2O RAID controller then you are trying to use the wrong
driver entirely.

http://i2o.shadowconnect.com/
Read here for more documentation.

Please confirm that your controller is or is not I2O RAID.

Comment 4 Dave Jones 2005-04-16 02:00:49 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.