Bug 128225 - yum fails when gpgcheck=1 and LANG=sk_SK
yum fails when gpgcheck=1 and LANG=sk_SK
Status: CLOSED DUPLICATE of bug 111022
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 09:17 EDT by Jan ONDREJ
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2004-07-20 09:17:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040618 Galeon/1.3.16

Description of problem:
I am using LANG=sk_SK (slovak language, but may be any other expect EN
or C) and yum always fails, when gpgcheck for archives is on.

Workaround:
  LANG=C yum install ...


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.export LANG=sk_SK
2.# set gpgcheck=1 for an repository
3.yum install A_PACKAGE
    

Actual Results:  [...SNIP...]
I will do the following:
[install: zsh 4.2.0-1.i386]
Is this ok [y/N]: y
Downloading Packages
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 339, in main
    clientStuff.download_packages(tsInfo)
  File "/usr/share/yum/clientStuff.py", line 1224, in download_packages
    rc = rpmUtils.checkSig(rpmloc)
  File "/usr/share/yum/rpmUtils.py", line 70, in checkSig
    error, siginfo = getSigInfo(hdr)
  File "/usr/share/yum/rpmUtils.py", line 86, in getSigInfo
    sigtype, sigdate, sigid = siginfo.split(',')
ValueError: unpack list of wrong size


Expected Results:  No error.

Additional info:
Comment 1 Seth Vidal 2004-07-20 09:20:59 EDT

*** This bug has been marked as a duplicate of 111022 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.